both MFT and MFT mirror are bad, please help!

Using TestDisk to repair the filesystem
Post Reply
Message
Author
marumarsu
Posts: 1
Joined: 06 Aug 2016, 18:47
Location: Finland

both MFT and MFT mirror are bad, please help!

#1 Post by marumarsu » 06 Aug 2016, 19:28

I recently bought a new HGST HDD for storing my old data, so i could reformat my older HDD and an SSD (because my old operating systems had corrupted somehow).

At the time, because i didn't have a working vista at hand i had to format the new HGST drive using a USB caddy and my W10 laptop.
My problems started when i had to decide whether i'd choose to format the drive as a GPT or an MBR.
I recalled having a seagate drive that had a 4TB partition and that it had worked on my vista, so i figured i'd go with GPT as MBR didn't allow bigger than 2TB partitions.

It was all going well, i was backing up my data from my old HDD and SSD to the new HGST drive.
The drive even worked on my other laptop which has a W7.
When i had backed up all my data to the HGST and had done a fresh vista installation on my SSD i went and tried if the new HGST would work, it didn't.
I couldn't see the HGST drive on My Computer, however i did see it in the disk management, but it said the whole drive was unallocated.
I tried it again on my W7 laptop and it worked flawlessly, so i put it back to my vista, but it still doesn't show up.

I tried reading about this and apparently vista doesn't recognize GPT drives. I thought if i would "initialize" the drive from disk management, it would somehow become active, but that was apparently a big mistake, it only messed up the drive even further. Now neither of my laptops can read the drive, but it does still appear on disk management. Only now it bugs me to format the disk, which i have no intention of doing because all my files are still there!!

I'm running testdisk right now at the moment, i'll post the logs when it finishes.
Though before i started the search i got a "Warning: Bad ending head (CHS and LBA don't match)" error.

Update (12.8 0:52): I cant run the search all the way as somewhere around 64% my computer starts freezing and i get a blue screen, after rebooting i get a "bootmgr is missing" error. I tried the REBUILD BS option but both boot sectors are bad.

Update (12.8 4:53) I tried GetDataBack and dear god it works FLAWLESSLY, i can see ALL my files, i'll just have to work out a way to recover most of them.

Update (15.8 22:05) I've gotten all my files back and the drive is back in business! All thanks to GetDataBack!

Sponsored links

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest