WD Red 3.0 tb recovery

How to use TestDisk to recover lost partition
Post Reply
Message
Author
jeffone
Posts: 1
Joined: 09 Aug 2016, 14:27

WD Red 3.0 tb recovery

#1 Post by jeffone » 09 Aug 2016, 14:46

Hello all, thank you in advance to all those who kindly reply to this post.

I am trying to recover as the subject suggests a WD Red 3.0 tb hard drive using testdisk and photorec. The drive was formatted NTFS using windows vista as one single partition. I first tried the testdisk on my laptop running vista connecting the drive with a sata to usb converter which was taking far to long because it was USB. my second option was to get an AMD machine repaired and run testdisk using a windows 2003 server install. This didn't work because it did not recognize the entire size of the drive only around 800 GB (this would be my perferred method so if i can make this work let me know). I then decided to use test disk under ubuntu that i could dual boot to using the same AMD machine.

when i run testdisk using ubuntu. it does not recognize the disk as efi gpt like it did under windows vista on my laptop and i have tried both intel and efi gpt under ubuntu. i cant figure out which is the correct of the two methods. also when it finally did complete this morning i pressed enter on what i thought was the correct partition and then highlighted the partition which i thought looked the correct size and tried to list the files but it said no files found. now what is weird is when i run photorec under ubuntu it sees the primary partition as EFI GPT and what looks to be the correct size. when i run it, is finding a lot of files that are on the drive. this tells me that the partition can be seen and the files are there. so why am i having such a hard time with test disk???

If you need to see the log file i can post one but i am rusty at ubuntu and don't know where to find it.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3619
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: WD Red 3.0 tb recovery

#2 Post by cgrenier » 10 Aug 2016, 16:07

Yes, the testdisk.log file content will help ;-)

A disk using an EFI Guid Partition Table should also have a PC Intel partition table with a single partition (max 2 TB) identified as EFI GPT. It prevents non EFI-aware disk software to see the disk as unused.
By default, PhotoRec doesn't let the user change force the partition table type.
I think that the EFI GPT signature is damaged and only the PC Intel partition table remains. It may explain why PhotoRec lists this EFI GPT partition.

You should use testdisk (7.1-WIP recommended), select the disk, force the type as EFI GPT, use Analyse/Quick Search/Deeper Search if needed to recover the NTFS partition.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests