found an MS Data partition, should be ext4

How to use TestDisk to recover lost partition
Post Reply
Message
Author
robyn
Posts: 3
Joined: 20 Aug 2016, 19:50

found an MS Data partition, should be ext4

#1 Post by robyn » 20 Aug 2016, 20:14

I have a PROBOX external 4-disk RAID enclosure attached to an Ubuntu 14.04 x86 system in a lab.
It is set up as one large ext4 file system.
The USB cable was inadvertently yanked while in use and now the file system cannot be mounted.
The mount command says wrong fstype, bad superblock, etc. The parted command said that the
primary GPT table was corrupt but the backup was okay, and could not show any partition information.
The gdisk command said the same thing, adding that MBR was protective, BSD and APM not present, GPT damaged.
It recommended disk verification and recovery and showed a single partition of about 2.7 TB which is what we expect.
No partition type or file system type was shown though. I ran 'v' for verify; it reported only the primary GPT table problem.
So I accepted the restoration from backup GPT table, then 'v' again, and verify very quickly said there were no problems.
Wrote the restored GPT to disk and exited.

Now parted can show a partition, but the file system type is not set, and the volume still cannot be mounted.
Using testdisk (at last!), I ran an analysis, and after a day it said "structure ok". It found two partitions, both marked P.
One large one is tagged MS Data, one small one is tagged Mac HFS. Selecting the large one, I could not display any files:
"not supported for this filesystem type".

How can I safely set the filesystem/partition type to ext4? The Linux choices in the partition type submenu are
Linux Raid (sic), Linux Swap, Linux LVM, Linux Reserved.

I read the recent thread titled "Recovering ext4 drive" but the details of that situation seem a bit different from mine.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3555
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: found an MS Data partition, should be ext4

#2 Post by cgrenier » 21 Aug 2016, 19:36

If a single MS Data partition is present and its size looks ok, run TestDisk, Advanced, Superblock and use the values with fsck.ext4 to repair the filesystem

robyn
Posts: 3
Joined: 20 Aug 2016, 19:50

Re: found an MS Data partition, should be ext4

#3 Post by robyn » 22 Aug 2016, 13:12

It found two: one quite large as expected, marked MS Data, and one quite small, which I did not expect, marked Mac HFS.
I'll have to check with the people who usually maintain this system to see if they know about the second one.

robyn
Posts: 3
Joined: 20 Aug 2016, 19:50

Re: found an MS Data partition, should be ext4

#4 Post by robyn » 23 Aug 2016, 17:50

Re the Mac HFS partition that testdisk found, I found out that the person who initialized the storage array did create a small
MacOS partition but thought he had deleted it afterwards.

In any case, at Advanced -> Type, I chose Linux Reserved, and then was able to choose ext4. Then it offered the option of
viewing files (which wasn't previously offered), but couldn't actually do it because the file system is damaged.
The Advanced -> Superblock you suggested also became available once I set the ext4 type. I ran it, and it reported three
superblocks. Comparing them to the results of "mkfs.ext4 -n", testdisk reported the last three in the list of two dozen or so
that mkfs.ext4 -n reported. I tried them all (not just the three that testdisk found) with "fsck.ext4 -n -b ...".
Every one of them failed with bad magic number in the superblock.

Not looking so good...

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests