External Hard Drive Recovery (2TB, HDD) Topic is solved

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Akilynn
Posts: 4
Joined: 07 Sep 2016, 13:59

External Hard Drive Recovery (2TB, HDD)

#1 Post by Akilynn » 07 Sep 2016, 14:08

Hello.

This might just be another normal case of recovery.

My problem is this: I accidentally formatted my ext. Hard Drive via Phone and used TestDisk to scan it. Following the tutorial (including Deeper Search), I could locate the lost partition and tried to rewrite it, but I was shown an error stating it cannot write the partition, although the Structure was said to be OK (1st recovery attempt was with a Mac). Can somebody explain me why it has happened?

Now I am rescanning the whole disk again. (Via Windows)

Thank you to whoever can help me.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3555
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: External Hard Drive Recovery (2TB, HDD)  Topic is solved

#2 Post by cgrenier » 07 Sep 2016, 15:55

By default, Mac OS X prevent write operation on disk with mounted partition. It's why the disk was listed as Read Only (RO) and why you should have got a warning message near the beginning.
Under Mac OS X, you need to use "sudo umount /Volumes/XXX" (adjust the command to match the partition name) before using testdisk.
As you are now under Windows, you should have no problem rewriting the partition table.

Akilynn
Posts: 4
Joined: 07 Sep 2016, 13:59

Re: External Hard Drive Recovery (2TB, HDD)

#3 Post by Akilynn » 10 Sep 2016, 18:14

Hello.

Thank you very much for the last post, Admin.

Still Deeper Searching the HDD (92% as of now) but somewhere in the middle, this appeared.

check_FAT: can't read FAT boot sector
Invalid FAT boot sector
0 D FAT32 LBA .....
FAT32 LBA ..... (The content of the dots are all identical.)

I am really worried about invalid boot sector. Does this mean I cannot rewrite the partition?

Thank you very much.

Akilynn

Akilynn
Posts: 4
Joined: 07 Sep 2016, 13:59

Re: External Hard Drive Recovery (2TB, HDD)

#4 Post by Akilynn » 10 Sep 2016, 18:41

I have scanned it. It told me that I cannot backup the lost Partition.
After Pressing A, I found this.

No partition ... 0 0 1 243200 254 63 3907024065

I really don't know what to do anymore.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests