Cannot Delete Recovered Files Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 14 Sep 2016, 02:36

Cannot Delete Recovered Files

#1 Post by WilburKlick »

PhotoRec was successful!

Now, I need help deleting a folder on my computer filled with large image files.

When I go to delete them, I'm warned that they are protected and I'm not the owner so I am not allowed to delete or make any changes.

There is only one user/profile on this computer.

How I got into this mess:

I accidentally deleted photos from my camera.

I installed TestDisk and used PhotoRec to recover all of the images on my SD card (which turned out to be a huge number of images).

After I copied the photos I wanted to keep, I tried to delete the huge folder that PhotoRec had created, but it wouldn't let me – protected, and I'm not the “owner” - so I have no right to delete.

I've opened as Administrator – still won't give me right to delete this folder or images.

When I go into Permissions as Administrator – the areas that would allow me to change permission are greyed out.

As you can tell, I'm not very computer savvy.
I think PhotoRec said something about working at the "root" level while performing photo recovery.

How can I get rid of this gigantic file of images now residing on my computer?

Thank you.

Operating System:

Linux Mint
(release # 17 / qiana; Kernel Linux 3.13.0-24-generic; MATE 1.8.1, 32 bit)


Dell Dimension 3000

memory = 2.0 Gib
processor: Intel Pentium 4,CPU 2.8 GHz

i686 (32 bit)

Sponsored links

User avatar
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Cannot Delete Recovered Files

#2 Post by cgrenier »

You need to take ownership of the directories to be able to delete the files.

Code: Select all

sudo chown -R user:user recup_dir.*
, replace user by your username.

Posts: 2
Joined: 14 Sep 2016, 02:36

Re: Cannot Delete Recovered Files - problem fixed

#3 Post by WilburKlick »

Thank you cgrenier!

That fixed the problem - "took ownership" of those locked folders and was able to delete them.