Lost Partition NAS, unable to mount in Ubuntu

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Kinggertos
Posts: 3
Joined: 23 Oct 2016, 20:35

Lost Partition NAS, unable to mount in Ubuntu

#1 Post by Kinggertos » 23 Oct 2016, 20:57

Hello,

After a weekend of searching i'm calling for help of this forum. (I'm no native english so excuse me for errors)

I have an old NAS, called CH3ENAS (single disk), it is a cheap sort of NAS with one HDD...
So I used the NAS for movies and photos, it worked very will for the last 3 years.

The last months, the NAS began to work very slow and i wanted to backup the data. The speed of copy is very slow. Normally around 1-2 MB/s but last weeks it was more like 300Kb/s, it is a 1000 GB disk, so it took ages to copy everything. So I wanted to put the HDD in my PC and copy it like that. Because the HDD is formatted in EXT2 filesystem (or XFS ????), the Windows PC can't read it so i downloaded Ubuntu and made a bootable USB stick.

In Ubuntu I have to mount the disk. It gives an error (Can't read superblock)
When I put the disk back in my NAS and in the configuration screen the disk is viewable, but not ready to use. SMART control says PASS, the disk is healthy but has to be formatted for first use... ?????
In my BiOS, the disk is OK.

So now I'm in the situation that I'm not able to acces the data on the disk anymore, not in Ubuntu and not in Windows.
Windows says the disk is healthy.

What did I do?

I downloaded a program to make the XFS of EXT2 disk readable in Windows -> It didn't work.
I used the partion utility by Windows 10, it says the disk is RAW format.
I downloaded testdisk, first in Ubuntu then in Windows.

Testdisk found a Linux partiton in the quicksearch, i could Write it to disk, but it doesnt work, my NAS can't acces the data.

I tried Phtotorec, photorec finds data and it is possible to restore it, but the files are renamed and not sorted in folders anymore. So I stopped the recovering process.

Everything is still on the disk, but there is a problem, recovering it with photorec is a last resort, but I wonder if it is possible to recover the lost partition, with the Direcories and files named correctly?

I never formatted the drive, I did not delete anything, so I don't know why this happens?

If anyone could help me with this, it would be amazing!

Thank you in advance.

Geert.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3623
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Lost Partition NAS, unable to mount in Ubuntu

#2 Post by cgrenier » 24 Oct 2016, 06:35

Despite the SMART status PASS information, a disk that goes slower and slower is usually riddled with bad sectors.
Boot from a Linux LiveUSB and clone the damaged disk to a new empty one using gnu ddrescue. See https://www.cgsecurity.org/testdisk.pdf for details.
Once the copy is done, remove the damaged disk and try to mount the partition from the clone. If it doesn't work, please post the testdisk.log file content (TestDisk, Advanced, List).

Kinggertos
Posts: 3
Joined: 23 Oct 2016, 20:35

Re: Lost Partition NAS, unable to mount in Ubuntu

#3 Post by Kinggertos » 24 Oct 2016, 08:17

Thanks, I look at it this evening, after work.
The disk is 1TB, I know the data on the disk is +/- 195 GB, can I clone just the data or is it really necessary to clone the disk on a 1TB disk?

I have enough space (+/-300 GB) free on another disk.

thx.

Kinggertos
Posts: 3
Joined: 23 Oct 2016, 20:35

Re: Lost Partition NAS, unable to mount in Ubuntu

#4 Post by Kinggertos » 24 Oct 2016, 19:02

Hello

I have read the manual and I think that I have to buy an other 1TB in order to clone the damaged disk.
For the moment I cannot buy an new 1 TB harddrive to go further with the recovery process. I'm very sorry but I'll buy it within a week or 3, then I will proceed and give feedback.

Thx a lot.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests