Recover RAID 10

How to use TestDisk to recover lost partition
Post Reply
Message
Author
PAULRICH
Posts: 2
Joined: 15 Nov 2016, 10:48

Recover RAID 10

#1 Post by PAULRICH » 15 Nov 2016, 10:56

Hi all,

So I just updated my mobo to the latest bios using the @bios utility. Upon restart, the RAID was no longer recognised, and intel rapid storage technology would no longer boot.

I updated IRST with the version on the gigabyte website, and now it is half working. It sees two of the drives as still being in the raid array, but the other 2 drives are "status:missing". It things the serial number of one drive is 43KNL0GBS:0

However the *actual* serial number is 43KNL0GBS. IRST does see the drive, but doesn't recognise it as being part of the array.

I have tried downgrading my bios unsuccessfully, gigabyte doesn't seem to want you to roll back versions.

I also changed my setting in the BIOS from AHCI back to RAID (though this was AFTER I had booted into windows a few times). I read that this can destroy your raid partition!


I've found your great tool and followed this post by another user:
DrChuckS wrote:Here is a follow-up. ASUS never sent me any response that helped. Their last suggestion was resetting the CMOS which did nothing.

So I followed the suggestion above which worked. Thanks!

1. Enter the Intel Rapid Storage utility upon boot (CTL-I)
2. Remove any partitions that are still shown as raid members from the failed raid volume. The volume will disappear.
3. Create a new raid volume using the same parameters used to create the original failed raid volume
4. Exit the utility
5. Continue to boot into Windows. Note: the new volume will not be visable in Windows yet.
6. Run the TestDisk program
a. Select the newly re-created volume created above (it will be listed)
b. Run analyse using Intel Structure
c. The Structure will be found and indicated as good
d. Write the partition table
e. Exit TestDisk
7. Reboot Windows

All is now well, the volume shows up, and all data is present.

The process is a bit scary but only took about five minutes to complete and really saved me a lot of hours it would have taken to recreate all the data! :D

I found the partition, and the files all seemed to be listed within it OK. I wrote it to the drive and rebooted.. but windows still doesn't show the drives.

Which of the settings should I be using once I have highlighted the array. Primary, logical.. etc? I can't find anything that explains these settings. I am currently running a deep scan, though it will take quite a while.

BTW I had four 3TB drives set to raid 10, so giving me a total of 6TB space. This was then split across two partitions to appear as two 3TB drives.


Many thanks for any help, I really need to recover these files!

Cheers
Paul

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3812
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recover RAID 10

#2 Post by cgrenier » 15 Nov 2016, 20:35

Please post a screenshot of Windows Disk Manager ouput.

PAULRICH
Posts: 2
Joined: 15 Nov 2016, 10:48

Re: Recover RAID 10

#3 Post by PAULRICH » 16 Nov 2016, 14:29

It is currently showing as a single unallocated drive (6TB in size). http://imgur.com/a/7v8mn

I have managed to rescue most of my files though using the 'list files' and copy commands.

So far I have only had 1 file fail - is there any way to find out which one this was?

I will rescue all of my critical files now, and then try to rebuild the RAID again after. Please let me know the best approach for this!

Appreciate the help
- Paul

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests