RAID 10 Partition Recovery Topic is solved

How to use TestDisk to recover lost partition
Locked
Message
Author
bmccord
Posts: 2
Joined: 30 Nov 2016, 15:47

RAID 10 Partition Recovery

#1 Post by bmccord » 30 Nov 2016, 16:04

I have a RAID 10 setup with 4x2tb drives, a couple days ago two of the disk got set to non-raid members and the raid failed. I have followed the following steps.
1) Enter the Ctrl-I configuration utility. Write your raid level, array size, stripe size and everything else that can be configured on a piece of paper, you’ll need this info later.
2) Set drives as “non-raid drives”
3) Reboot and create a new array identical with all the specifics you wrote down in step one.
5) Start testdisk.
Started testdisk and searched for EFI GPT, after a deep search it returns the following

Image

The original partition was 3.7gb. Trying to list the files of the MSdata partitions results in the Can't open filesystem. filesystem seems damaged error.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3555
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: RAID 10 Partition Recovery

#2 Post by cgrenier » 01 Dec 2016, 06:52

Try PhotoRec for a few minutes. If all recovered files looks junk or small files, the raid parameters are probably wrong. Find the correct parameters and try again.
Once it's ok, try again testdisk.

bmccord
Posts: 2
Joined: 30 Nov 2016, 15:47

Re: RAID 10 Partition Recovery  Topic is solved

#3 Post by bmccord » 02 Dec 2016, 08:22

I seem to have figured it out. Here's what I did for anyone with similar problems.

1. Initialised the raid in Windows Disk Management as a GPT
2. Ran Testdisk again, After a couple seconds of deep scanning a partition showed up that was the right size, however upon stopping the scan it returned the following

Image

I then found the following thread here viewtopic.php?f=5&t=1939&p=7033&hilit=c ... 0000#p7010 Which documented a similar problem.

I increased the cylinders by 6 as the OP did.
Once rerunning the scan in TestDisk the same partition came up but this time I was able to list the files and copied everything to a drive.
I then attempted to write the partition but TestDisk gave me an error saying the partition couldn't be written, however when I opened Disk Management and rescanned the partition showed up and I am able to access all the files.

Thanks for the help!

Locked

Who is online

Users browsing this forum: No registered users and 2 guests