reformatted an encrypted drive Topic is solved

How to use TestDisk to recover lost partition
Locked
Message
Author
hozee1978
Posts: 2
Joined: 16 Feb 2017, 03:56

reformatted an encrypted drive

#1 Post by hozee1978 » 16 Feb 2017, 22:05

Hello and thank you for this forum. I have a problem in that I am unsure of what to do next. I encrypted an entire drive with veracrypt. I accidentally did a quick format (fat32) on that drive. I used ddrescue to clone it so that I now have two identical drives in case I mess up the first. Test disk does find the NTSF partition but of course it can't list the files as it is encrypted. My dilemma is that in order to write the partition I must change the partition type. Should I change ti to logical or primary? Also any help as to how to get it to once again mount in veracrypt would be very welcome.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3619
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: reformatted an encrypted drive  Topic is solved

#2 Post by cgrenier » 17 Feb 2017, 18:47

Read http://www.cgsecurity.org/wiki/Recover_ ... ypt_Volume (truecrypt is the old name of veracrypt)
- Corrupted Standard Volume header
- Recovery using whole decryption
You may be able to recover your data via one of this 2 methods.

hozee1978
Posts: 2
Joined: 16 Feb 2017, 03:56

Re: reformatted an encrypted drive

#3 Post by hozee1978 » 17 Feb 2017, 21:27

thank you for your reply. I went ahead and changed the partition to primary and used the write option from there. I was able to recover the encryption header and mount the volume with veracrypt but then kept being faced with "windows needs to format this volume" when I tried to access it. I had purchased R-studio a few years back so I tried mounting the volume and then running R-studio. I got lucky. I got all of my files back and none were worse for the wear. Thank you so much for your tool, and thank you so much for taking the time to help people use it correctly.

Locked

Who is online

Users browsing this forum: No registered users and 0 guests