No partition information and Input/output error

How to use TestDisk to recover lost partition
Post Reply
Message
Author
orbit503
Posts: 2
Joined: 10 Mar 2017, 15:07

No partition information and Input/output error

#1 Post by orbit503 » 10 Mar 2017, 15:23

Hello,

I have a HFS+ SSD that was retrofitted in a Mac, which suddenly stopped working. It's now hooked up on a Linux box, showing with "lshw -C disk".

When I try testdisk on it, it shows no partition information, running Quicksearch or Deepsearch doesn't find any as well. The log fills up with:

Code: Select all

...
file_pread(5,1,buffer,2198(1/4/23)) read err: Input/output error
file_pread(5,1,buffer,2199(1/4/24)) read err: Input/output error
file_pread(5,14,buffer,2200(1/4/25)) read err: Input/output error
file_pread(5,1,buffer,2216(1/5/9)) read err: Input/output error
file_pread(5,1,buffer,2263(1/6/24)) read err: Input/output error
...
I tried using ddrescue as per suggestion, which also can't read anything and basically results in a 0 bytes Images with 0 bytes rescued per stats.

Is there anything left to do or can I assume the SSD has a severe hardware failure that is not recoverable? I did not try to partition/reformat it yet!

Thank you in advance for any advice,

Orbit503

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3765
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: No partition information and Input/output error

#2 Post by cgrenier » 10 Mar 2017, 18:21

Reformating will not work. The flash controller is probably damaged. If the data are of great value, you can always contact a data recovery company.
Otherwise use the warranty to replace the SSD.

orbit503
Posts: 2
Joined: 10 Mar 2017, 15:07

Re: No partition information and Input/output error

#3 Post by orbit503 » 10 Mar 2017, 18:56

Thank you for the quick reply!

You confirmed my guess. Just for clarification: the "read error" on every block basically means it's impossible to get any data at all from the storage itself, while the device (controller) as such is visible?

There is a firmware update for the drive available (Samsung 470 series), I'll try that just for the fun of it, but my expectations are low.

Thanks for your work!

Best regards,
Orbit503

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest