PhotoRec is taking exponential number of hours to finish

Using PhotoRec to recover lost data
Post Reply
Message
Author
aludra
Posts: 1
Joined: 15 Mar 2017, 17:12

PhotoRec is taking exponential number of hours to finish

#1 Post by aludra » 15 Mar 2017, 17:30

First of all, I want to thank cgrenier for all the hard work developing this amazing app, making it free and also his activity in this forum. most respect main.
Also, I want to ask everyone using this tool to DONATE , even if it's a small amount of money because we need to support each other.

Now to my question: I am trying to recover files from a "dead" HD, I am pretty sure it has bad sectors or even physical damage, Anyhow at least the drive is detected, so is the two partitions.
I started using photorec 7.0 and it started recovering files, the problem now is that after many hours the remaining time is augmenting as well, so for instance when I started writing this post it was 734 hours and now it's 742 hours.
I do recover files, though , it is slow but it is working.

What should I do? , Is this normal? will it move faster once all the bad sectors are skipped? It's already been running for 37 hours

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3809
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: PhotoRec is taking exponential number of hours to finish

#2 Post by cgrenier » 16 Mar 2017, 18:32

Stop PhotoRec 7.0
Download and extract the latest 7.1-WIP
Copy the photorec.ses file from testdisk-7.0 directory to testdisk-7.1-WIP directory
Run PhotoRec 7.1-WIP and ask it to resume the recovery

Does it solve the problem ?

FDD2020
Posts: 2
Joined: 03 Jun 2017, 15:38

Re: PhotoRec is taking exponential number of hours to finish

#3 Post by FDD2020 » 03 Jun 2017, 15:44

Had the same ordeal with a drive with plenty of bad sectors. (while using 7.0 & 7.1)

What worked for me, Create an image of the HDD with ddrescue (not dd_rescue, that's a old and potential dangerous program when used incorrectly)

Then let PhotoRec/Testdisk do it's thing, load up the image OR dump the RAW image on a formatted healthy drive. Will still take a good night depending upon configuration, size of the hdd/img that's needing to be recovered and the filter options used

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests