Failed to read last sector

Using TestDisk to repair the filesystem
Post Reply
Message
Author
ubeu
Posts: 1
Joined: 02 May 2017, 16:29

Failed to read last sector

#1 Post by ubeu » 02 May 2017, 16:48

I have this external hard drive that is corrupted to some extend. Testdisk was able to restore the ntfs filesystem, but while the hdd's size it 4TB, the number of sectors is much higher (disk end after the disk's physical end). At the same time, Gparted does detect the correct size of the hdd (3.64TB).

Ubuntu and gparted display the same error message: Failed to mount:
"Failed to read last sector (976558590): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
or it was not setup correctly (e.g. by not using mdadm --build ...),
or a wrong device is tried to be mounted,
or the partition table is corrupt (partition is smaller than NTFS),
or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?"


I already ran photorec, resulting in the recovery of files without their original names or folder structure.
Now I would like to restore/access the original filesystem, folders and files.

Does anybody have advice on how to try to accomplish this?
Perhaps, which steps could I take to correct the number of sectors?

Thanks

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3555
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Failed to read last sector

#2 Post by cgrenier » 03 May 2017, 06:13

Run TestDisk, Advanced, List. Do you see your files ? If it's the case, you can copy them and keep the original filenames.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests