I don't know what happened/to do

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 17 May 2017, 19:45

I don't know what happened/to do

#1 Post by Max2017 »

Hello there, this is what happened just yesterday.

I bought a M2 SSD (samsung 960 evo) for my notebook and just installed it.

I had a wd blue (1tb) which was splitted in 2 partition ( C: for boot and D: for data).
I used samsung data migration software and successfully cloned the wd boot partition (C:) on my ssd.

Then i restarted and configured it for boot from the new SSD.
All went very good, system very fast and absolutely no error nor missing files.
Then i just formatted the old C: WD partition from windows disk utility.
It said that there was unallocated space after the format, and that was normal.
Then i tried to full increase the D: wd partition with the new unallocated sector.

- Here is what the beautiful windows did to me. Errors, errors, errors, no space available everytime i tried to put the wd partitions back together.

I downloaded GPart and booted it with a pendrive. I tried to increase the D: partition but it failed.. so i just formatted the old wd C: again..

after the system restarted i noticed that Gpart used to format that partition as a dynamic disk, and the D: partition with ALL MY DATA JUST DISAPPEARED (probably filesystem corrupted.. but i didn't touch that partition!!!) (ohmy..).

Just rebooted Gpart and put wd C: back to base partition.. rebooted and both partitions now appear to be a fully unallocated hard drive.. when i click on D: now it just says filesystem damaged (and after a few tries on TestDisk now it says that structure is damaged)..
Notice that the wd hard drive is just new, not any problem like sectors there were on it before yesterday...

What would you suggest me to do? I would like to rebuild the filesystem (which WAS NOT TOUCHED!!!) and access all my data as it was before. What options do i have to select on TestDisk?


Sponsored links

User avatar
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: I don't know what happened/to do

#2 Post by cgrenier »

Try TestDisk, Analyse, Quick Search, Stop, Deeper Search.
Use 'p' on each partition to list your files. If you see them, set the partition as P(rimary) or *(bootable).
On next screen, choose Write, confirm, Quit and restart your computer.
If it doesn't work, use PhotoRec to recover your data, it will not recover the original filenames.