WD MyBook saga

How to use TestDisk to recover lost partition
Post Reply
Message
Author
mulvaz
Posts: 2
Joined: 05 Jun 2017, 05:39

WD MyBook saga

#1 Post by mulvaz » 05 Jun 2017, 06:46

Hi,

I have/had an external 4TB WD MyBook with a fried usb board.
So I bought another empty USB 3 enclosure thinking that I would just fire it up in that as I had done with so many disks in the past.
When windows 10 recognised it it of course asked me to initialize it. I of course said "Ok" as I have done some many times before adding disks to servers and what not. DOH>.
Anyhow that's what brought me here. Windows created a 2TB NTFS partition (windows 10 pro max size I'm guessing) on it with nearly 2TB Unallocated space.

So I ran TestDisk starting following the testdisk step by step recovery for NTFS scenario and it found pretty quickly my old file system on a Quick Search, pressed P and was able to navigate all folders and files.
(Not a complex file system, only one NTFS partition, with only Movies folder and two or three other.. Home Videos etc).
So I grabbed all urgent data off before trying to restore the partitioning/filesystem. Good news here.

Then I think I made my second and third mistake... :)
I stopped following the Step by Step as the scenario seemed different to my issue.
I tried the Rebuild BS checked I could access files by hitting P, and then TestDisk crashed out.
Tried this 2 or three times with the same result. The last time I tried it I accidently somehow hit "Write" without checking I could access files and it succeeded.
Now the when I scan it with either Quick Search or Deeper Search it says the filesytem is damaged.

Deeper Search now shows
>D HPFS - NTFS 0 32 33 267349 121 36 4294967296 [Data1] (where Data1 is the old name of my volume)
D FAT16 >32M 113991 80 27 334817 147 45 3547573930
* FAT32 LBA 461938 173 29 466648 141 37 75664143 (Highlighted green)

The two additional snippets of info were that
1. TestDisk was saying "Warning: number of bytes per sector mismatches 4096 (NTFS) != 512 (HD) Error" not sure if this meant that the disk was initially configured with 4k clusters and not the default 512 or that TestDisk was trying to look at 4k clusters and not 512...Maybe this means something else entirely.
2. When it errored the logs showed in the logs a repetitive error like lseek err Invalid argument file_pread(6,1,buffer,7813971995(486397/66/33))

I am reluctant to try anything else as I am just making things worse at this point.

Any advice would be appreciated. Logs and Dump file attached.
Attachments
testdisk-7.1-WIP.zip
(21.72 KiB) Downloaded 10 times

Sponsored links

mulvaz
Posts: 2
Joined: 05 Jun 2017, 05:39

Re: WD MyBook saga

#2 Post by mulvaz » 12 Jun 2017, 05:06

Anyone? Bump....

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest