Can't recover LUKS partition + boot XFS of a dual boot

How to use TestDisk to recover lost partition
Message
Author
festie
Posts: 1
Joined: 19 Jun 2012, 23:15

Can't recover LUKS partition + boot XFS of a dual boot

#1 Postby festie » 19 Jun 2012, 23:31

Hi there,

I lost a hard drive with quite recent, quite critical and not backuped information which I need to recover or I'll be in serious trouble.
First of all, the partition is in a HP elitebook 8440p. This is not a lesser detail, as HP ships these machines with stupid useless "security" software that relates its factory windows install with the machine's bios and also creates some wacky partitions which I got errors from right the first time I partitioned to install linux there in dual boot mode. For instance, once I had my linux running, I was never able to run cfdisk without an error.
The HP machine had about 4 partitions by default, and I added 3.
One was my /boot in plain XFS filesystem, another was a large XFS partition I used for non sensitive files something like /home/archives, and then
was my root partition with DM-Crypt/LUKS, which means it was a mapped part. The content of that LUKS was
XFS too.
I had to reinstall windows 7 and somehow, after the install, despite I'm completely sure I wrote the part in the right place, those 3 partitions I wrote above about appeared from then on as one allegedly "unallocated" mass of storage, from which, when I'm able to mount I see the data that used to be in /home/archives alone, while the partition is stated to have the size of the three original partitions sumed up.
TestDisk happens to be the only tool I ran so far that actually realizes there used to be something else there, but is unable to recover those partitions that apparently sees (it doesn't see the LUKS I'm afraid, tho).

Any help with this? I'm in SERIOUS trouble with this matter.

Thanks in advance

Sponsored links

Return to “Partition Recovery”

Who is online

Users browsing this forum: No registered users and 1 guest