CF card reading as 33Mb instead of 32GB

Using TestDisk to repair the filesystem
Post Reply
Message
Author
TonyTone
Posts: 1
Joined: 16 Jul 2017, 23:39

CF card reading as 33Mb instead of 32GB

#1 Post by TonyTone » 17 Jul 2017, 00:19

Details:
Shooting with a Canon 5D mkiii
Lexar Professional 1066x
32GB UDMA7
This is a legit card I've used for over a year and I've never experience an issue like this.

I was on a photo shoot about 2 hours into shooting, and the card stopped working. Error message on the back of the display read, "Card1 cannot be accessed Reinsert/change the card or format the card with camera."

On the top of the camera display, it showed 'err'

Getting back home to transfer images onto computer. When inserting the card, it displays as if it is unformatted, I get the windows dialog that asks if I want to reformat. I've looked at the disk using Testdisk 7, and the card is reading as 33 MB / 31 MiB - CHS 4 255 63 instead of a 32GB card, so it looks like the partition and/or MBR must have gotten corrupted. I've tried a myriad of recovery tools to try and pull the images off the card, but nothing is reading the card correctly. I've found solutions that say to reformat the card, then use the recovery tools to do a deep search to recover the files. Windows is unable to even read the card, formatting doesn't work.

Does anyone know how to fix this? Do I need to first fix it so that it reads as 32GB? If so, how do I do that?

When I analyze the disk it says, "Partition sector doesn't have the endmark 0xAA55", deeper search doesn't find anything.

Opening the disk using WinHex seems to show the full capacity of the card, but I don't know how to use the program so I don't want to break anything.

Thanks in advance!
Attachments
disk2.jpg
disk2.jpg (44.8 KiB) Viewed 70 times
disk.jpg
disk.jpg (71.48 KiB) Viewed 70 times

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3626
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: CF card reading as 33Mb instead of 32GB

#2 Post by cgrenier » 17 Jul 2017, 06:51

The CF card capacity is wrong, it's a hardware problem. You need to contact a data recovery company to recover your data.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest