Dynamic Disk Raid 0 and Formatted

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Mikungfu
Posts: 2
Joined: 04 Sep 2017, 02:50

Dynamic Disk Raid 0 and Formatted

#1 Post by Mikungfu » 04 Sep 2017, 03:16

Hello everyone,

This is my post here, which I'm making after weeks of internet research, software trials and countless data recovery attempts.

This is my current and admittedly very complicated situation:

a) Two WD Velociraptor HDD Dynamic Disks in RAID 0, for video file storage. It was software RAID 0 through Windows 7 Disk Management. Another identical WD Velociraptor as system disk.

b) I had a different physical drive (but the exact same model) as system drive and I was trying to restore a system image backup on it. Something disconfigured in the System Recovery and I ended up installing the System Image in one of the Dynamic disks. Part of the data I had in that disk of the array was overwritten by the partition created for windows. the rest of the disk shows as unnalocated, just like the second disk of the array. So much for my Raid 0 and for my files.

c) I never really booted that windows installation till the end but when I realized something was wrong, windows was already repairing its installation for some reason so... I don't know if that counts as writing data after the format.

d) I tried several softwares (Recuva, EaseUS, ReclaiME, etc...) but so far most of the videos files I manage recover are corrupted. Some play and are incomplete. Some are mixed with other videos in the same file... Some are ok. Big mess!..

So... I'm a bit lost now and don't know how to proceed. To make things even worse, WD Data Lifeguard software says that this disk that was overwritten, has unreadable sectors. I'm not sure if these are "hard" or "soft" bad sectors. I'd like to believe they are "soft" due to all the mess that's happened... And all 3 disks were bought at the same time back in 2010 and all the others are healthy like a tank.

What are my best options? Unformat the disk first to its original state and then try rebuilding the array as much as possible, so that I can try to recover the videos? How do I do that? What do I use for each step in terms of software? Or is everything lost? I'm currently running checkdisk on the formatted disk and the cylinder analysis is at 93%. sometimes it becomes very slow or static and sometimes it goes pretty fast.

Any ideas would be most appreciated... I had one folder there in particular which had my most valuable work in years and I hadn't finished editing it. If I loose the original files, I loose everything because for some incredibly stupid reason I had no backups. I had backups of most everything else except the most important thing and I can't even remember why I did such a stupid thing. Lack of storage I suppose but, even then... It was the most important. I don't get it. :oops: :roll:

Thanks in advance!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3754
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Dynamic Disk Raid 0 and Formatted

#2 Post by cgrenier » 04 Sep 2017, 06:32

As your disks were in Raid 0 (not Raid 1), if a single disk has a problem, all your data are lost.
You need to reconfigure the Raid 0 as it was previously. Avoid to format anything.
Once it's done, try TestDisk on the Raid0 to recover your partition. If it doesn't work, try PhotoRec.

Mikungfu
Posts: 2
Joined: 04 Sep 2017, 02:50

Re: Dynamic Disk Raid 0 and Formatted

#3 Post by Mikungfu » 04 Sep 2017, 11:50

cgrenier wrote:
04 Sep 2017, 06:32
You need to reconfigure the Raid 0 as it was previously. Avoid to format anything.
Once it's done, try TestDisk on the Raid0 to recover your partition. If it doesn't work, try PhotoRec.
Many thanks for your reply.

But like I said, I did accidentally create and format a 120GB partition within the 600GB disk, by installing there a Windows system image... So that much harm is done. Can I undo that and bring back the disk to its original state (or almost)? How do I do that, can you advise me on tools to do it?

From what I understand, the best approach is to first try and restore the drive that has been partially formatted as close as possible to its original state, so that I can rebuild my RAID 0 array, with the other untouched drive (I don't even know if 2 dynamic drives striped through windows Disk Management can be considered a proper RAID 0).

Update: I seem to have rebuilt the Raid 0 array with DMDE. It is now cloning an img to a different drive... And it's slow as hell.
BUT, DMDE didn't even try to read the data which was overwritten by the Windows Image Backup installation. This is why I thought that it would perhaps be better if I could somehow first "undo" the formatting of the 120GB partition created by this Windows accidental install. Is there any way of doing that??..

New Update: Ok at 43% cloning grinded to a halt and DMDE started constantly returning the following error message: WinError 55 - The specified network resource or device is no longer available.. I chose "ignore all" but I can see there are hundreds of those consecutive errors. Can the disk be failing OMG... The last thing I needed on top of all that already happened to this disk is a mechanical problem and the disk dying on me. It's like I've been cursed to loose this precious work...
DMDE.png
DMDE.png (33.65 KiB) Viewed 119 times

Newer Update:
I am now trying the approach of creating separate images of each drive with R-Studio, in order to later try and rebuild what can be recovered from the array, without having to read from the physical hard drives themselves, just in case they are not mechanically well.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests