Infinite copy loop

Using PhotoRec to recover lost data
Message
Author
mfseeker
Posts: 1
Joined: 20 Jun 2012, 19:53

Infinite copy loop

#1 Postby mfseeker » 20 Jun 2012, 20:06

I have finally succeeded in getting TestDisk to rescue most of the files on a previously unavailable partition. This is an ext4 partition on a drive that also contained a healthy partition. The sick partition would sometimes mount and sometimes not. Even when mounted it would not show the files it contained. I worked on it for two weeks using a variety of tools including TestDisk and PhotoRec. For some reason this morning it showed me the file structure of the sick disk. I immediately found and copied the crucial file that had precipitated all of my efforts. So, I thought, why not copy all of the user's directory to another drive. This copy seemed to be working fine, but after a few hours the target drive ran out of space. Investigation revealed that the copy was creating an infinite loop of nested directories and files like this:

Home|Users|Barbara|Desktop|OldFiles|Documents|Barbara|Desktop|OldFiles|Documents|Barbara|Desktop...ad infinitum.

I would like to be able to break this loop so as to safely copy any remaining files in Barbara's home directory.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3059
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Infinite copy loop

#2 Postby cgrenier » 07 Jul 2012, 11:09

Use Ctrl-C to stop the copy.
Since March 2011, TestDisk uses some protections against directories creating an infinite loop. Try a more recent version.


Return to “File recovery”

Who is online

Users browsing this forum: No registered users and 1 guest