Trying to recover 0kb files

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 10 Sep 2017, 14:09

Trying to recover 0kb files

#1 Post by mike3243 »

I have a 3TB WD Passport Drive. Yesterday I plugged it in and Disk Management showed it as unallocated.

So I ran testdisk to rebuild the BS. It did. But the weird thing was that the drive still showed as unallocated.

Then (probably stupidly), I ran chkdsk /f on it. All of my files and folders appear, but probably 50% of them show as 0KB.

But now, Disk Management shows one partition of 2048GB and another at 1677.99GB that is unallocated.

My drive initially had about 800GB left of free space.

Question is... is there anything I can do to get these files back, or am I just hosed?

Sponsored links

User avatar
Site Admin
Posts: 5306
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Trying to recover 0kb files

#2 Post by cgrenier »

Try TestDisk, Advanced, Undelete.
If you do not recover your files this way, use PhotoRec. It will not recover the original filenames but it should recover your data. (You may have to use [Whole] instead of [Free]).
Note that you need a lot of free space to store the recovered files and it must be on another disk, at least on another partition than the source.