4TB USB HDD with sector size mismatch.

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
OldLady
Posts: 1
Joined: 06 Oct 2017, 08:36

4TB USB HDD with sector size mismatch.

#1 Post by OldLady »

Hi!

First, thanks from your great work and excellent program.

I bought an USB 4TB HDD, I format it with two partitions, 1st a 2.2 NTFS primary and 2nd Secondary + EXT4 1.7 Partition.

Seem the USB_2_SATA do a trick and use the 512 bytes sector as 4k or something like that, if I unplug the HDD from the enclosure and connet direct to the sata port the S.O (ubuntu) don´t work because this mismatch.

I want to use the HDD direct to motherboard a put the enclosure to the garbage directly :lol:

I ran testDisk and it sais to me:

Code: Select all

Warning: number of bytes per sector mismatches 4096 (NTFS) != 512 (HD)
and there is the full log after 7 hours:

https://gist.github.com/anonymous/cac8a ... 3c8dcbbe5e

What is the best method to gain access to all my data?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: 4TB USB HDD with sector size mismatch.

#2 Post by cgrenier »

After Quick Search, use 'p' to list the files from each partition.
If it works, choose Write, confirm, Quit and restart your computer.

Locked