"All ok" but Test Disk fails

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Posts: 1
Joined: 01 Dec 2017, 22:53

"All ok" but Test Disk fails

#1 Post by gehtjanx » 01 Dec 2017, 23:07


Had a crash (PC suck), after that CHKDSK was executed. It got stuck at phase 2 at 43%, started again, but never finished.

I removed the HDD and connected it to another PC, but the computer tells me I have to format it (no access in Explorer).

With the program "GetDataBack" I can access the data within 2 minutes, all files are available. But: The results cannot be written to disk (NTFS table or MBR or whatever it is called)

TestDisk does an analysis and but says "it's corrupted/destroyed". But there was no option to recover it.

Tried other programs, but they don't work either.

Then I tried the option "write test MBR" but now TestDisk finds even fewer partitions - GetDataBack works as well as before.

I've copied all the files now, but I hope I can avoid formatting it and install everything from scratch again. So I would prefer to repair this HDD because everything is still accessible. The HDD SMART values ​​are all OK. However, CHKDSK can not delete an entry and can not continue.

Can someone explain what I need to restore that? Can not be that hard if GetDataBack did so fast and finds everthing.

Greetings and thanks, otherwise I have to format everything again and make it new.

Sponsored links

User avatar
Site Admin
Posts: 4637
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: "All ok" but Test Disk fails

#2 Post by cgrenier » 02 Dec 2017, 09:13

I think there are bad sectors despite the SMART "Ok" status.
You should copy all your files on another disk and avoid using the original disk.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 1 guest