SD card formatted, but need files

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
eiger3970
Posts: 1
Joined: 04 Jan 2018, 05:35

SD card formatted, but need files

#1 Post by eiger3970 » 04 Jan 2018, 05:40

Hello,
a Nikon SD card was accidentally formatted over. (not sure if a soft or hard format).
I ran a photorec command and received error:

Code: Select all

sudo photorec /media/user/3765-3831/
PhotoRec 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Unable to open file or device /media/user/3765-3831/: Inappropriate ioctl for device
I checked the permissions which seem okay with read, write and execute access:

Code: Select all

$ ls -l /media/user/3765-3831/
total 512
drwx------ 1 user user 131072 Jan  1  2016 DCIM
drwx------ 1 user user 131072 Sep  4 10:24 NCFL
-rwx------ 1 user user    512 Jan  1  2016 NIKON001.DSC
drwx------ 1 user user 131072 Sep  4 10:32 NSM
Any suggestions please?
Last edited by eiger3970 on 05 Jan 2018, 00:08, edited 1 time in total.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4241
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: SD card formatted, but need files

#2 Post by cgrenier » 04 Jan 2018, 09:03

Run PhotoRec without argument and select the device corresponding to your SD card instead of the directory where the SD card is mounted.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests