My disk has a none partition table

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Geo52rey
Posts: 1
Joined: 28 Jan 2018, 03:33

My disk has a none partition table

#1 Post by Geo52rey » 28 Jan 2018, 04:09

Originally, the disk was formatted to NTFS with a MBR partition map by the manufacturer of my computer. A while back, I reformatted the partition to vfat until I figured out the hard way that symbolic links don't work on vfat which makes the partition very limited in usefulness on my Linux system. Since Linux loves its ext4 filesystem, I just changed it to that, but I think I may have done it slightly wrong. I used the command mkfs.ext4, but as the argument I put /dev/sda instead of putting /dev/sda1.

Recently, I tried shrinking the partition in order to add a new partition in gparted. This is where it gets weird. After I shrank the partition, it has an unformatted portion of the original partition. In addition, the original partition cannot be moved left at least in gparted.

This left me to do a bit of research and I found things about gdisk and testdisk. When I run gdisk on the drive, it sees that there is a none partition table on the drive and tries to setup a gpt partition table on the drive. The only issue is that it says that it will delete partition data. I don't want to lose my 100GB of data on the disk especially when I don't have a drive available for backup.

When I ran testdisk on the drive, it also concluded that it has a none partition table on it. It saw the partition that was there and the reminiscents of a Windows installer, probably from the manufacturer, when I chose the none partition map at the beginning. If I choose others, it only shows parts of the filesystem that's on the drive with some filesystems that don't exist in the middle of the only filesystem that should be there.

The drive mounts perfectly and I read and write without issues, but I can't partition it since there is no partition table. Maybe if there is a program that moves data without limitation, then I could move the partition over 512 bytes the allow for an MBR partition map to be made without corrupting my data.

All in all, I just don't want the data on my drive to be deleted. Is there a fecable solution to this? Or do I just need to delete the entire drive to make the new partition table?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4123
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: My disk has a none partition table

#2 Post by cgrenier » 28 Jan 2018, 11:29

Yes, you have to backup your files, create a partition table, create a partition, format it and restore your files.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest