Extremely slow RAW partition image

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
IulianDita
Posts: 4
Joined: 26 Feb 2018, 10:01

Extremely slow RAW partition image

#1 Post by IulianDita » 26 Feb 2018, 10:09

Hello.

I got an external 2TB WD My Passport Ultra that appears to be RAW in disk management.
TestDsik is telling that there is a partition, I can list the files, but when I ran the imaging option, after 24h it only saved 1.3GB of data (I had to stop it).
Is this normal? Can I speed it up somehow?

Also, the computer is super slow processing any kind of input with the disk connected. It takes a few minutes to process any command, from TestDisk or any other application.

The hardrive is hardware encrypted / password protected (using the WD utility), and from the moment I plug the disk it takes about 10-15 minutes until I can start the imaging option in TestDisk. The WD utility is telling me that there is also a new firmware update available for my disk. Should I try to run that first? Should I try to unencrypt / remove the password protection first)

Thanks for any advice and for these amazing tools!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4333
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Extremely slow RAW partition image

#2 Post by cgrenier » 27 Feb 2018, 07:26

Try to clone the disk using ddrescue from a Linux USB key, read https://www.cgsecurity.org/testdisk.pdf , it may give better performanse.

IulianDita
Posts: 4
Joined: 26 Feb 2018, 10:01

Re: Extremely slow RAW partition image

#3 Post by IulianDita » 27 Feb 2018, 15:48

Alright, will try that. Thanks for the suggestion.

BTW, I updated the firmware and removed the password protection. Each operation took roughly 30 minutes.

IulianDita
Posts: 4
Joined: 26 Feb 2018, 10:01

Re: Extremely slow RAW partition image

#4 Post by IulianDita » 28 Feb 2018, 14:29

DDrescue runs for 20h on a live Ubuntu session.
It recovered so far 2.5GB (0.12%), with no bad sectors but with 5 read errors. Average speed: 36KB/s. Estimated time remaining: 2126d 59m. :|
Is there a chance it will actually finish in a few days, not years? Maybe after getting past the bad portion?

Any advices?

IulianDita
Posts: 4
Joined: 26 Feb 2018, 10:01

Re: Extremely slow RAW partition image

#5 Post by IulianDita » 01 Mar 2018, 10:36

After almost 2 days, still same speed. I stopped it and ran it again, this time adding -n -r1 -c16 parameters (it picked up exactly where I stopped it) and now the average speed is around 90KB/s.
Still 300+ days left :(

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest