Bug in testdisk 7.1 ?!?

TestDisk benutzen um verlorene Partitionen wiederherzustellen
Forum rules
Your help is welcome: there are currently few answers or none to most message posted in the German forum!
If you want to post a request for help, please consider using the English forum.
Post Reply
Message
Author
intru
Posts: 1
Joined: 27 Mar 2018, 17:58

Bug in testdisk 7.1 ?!?

#1 Post by intru » 27 Mar 2018, 18:13

Hi,

ich hab irgendwie das Problem, dass meine externe WD7500KMVV (USB) mehrfach unter Windows nicht Ordnungsgemäss ausgeworfen wurde und seit dem nicht mehr richtig erkannt wurde. Die Platte wird als 698 GB Raw angezeigt.

Nun habe ich mithilfe von testdisk versucht, dieses Problem zu beheben aber testdisk hat zwar diese Partition gefunden aber sonst absolut NICHTS...

Vor lauter Verzweifelung habe ich dann unter Windows chkdsk (laufwerksbuchstabe) /f gestartet und dann abgebrochen.

Dies hatte zur Folge das der MBR neu geschrieben wurde und ab diesem Punkt hat testdisk die ganze Verzeichnisstruktur und alle Dateien finden können. Unter Windows wurde das Laufwerk zwar gefunden aber ohne weitere Informationen und "leer". Ich wollte dann über testdisk diese Dateien kopieren nur das ging, fragt mich nicht warum und wieso, überhaupt nicht. Ist immer mit Fehler abgebrochen.

Da nun über testdisk die Daten ordnungsgemäss angezeigt wurden, dachte ich könnte einfach mal den MBR über testdisk neu schreiben. Dies würde den Fehler dann richtig reparieren.
Also wählte ich diese Option aus, bestätigte 2 mal mit "Y" und startete neu und ... :shock:
Aus meiner netto 698 GB Platte ist eine netto 2048 GB Platte geworden.

testdisk hat mir komplett falsche Daten in den MBR geschrieben!!! Wenn ich nun über Windows chkdsk diesen Fehler beheben möchte, sagt er mir das dies nicht möglich ist.
testdisk kann auch keinen MBR mehr schreiben da er wohl das gleiche Problem wie chkdsk nun hat...
Ich habe erst mal stundenlang nach den richtigen chs Daten der Platte gesucht, diese auch endlich gefunden und per Hand in testdisk eingetragen... dies hat zur Folge das die Platte nun wieder richtig angezeigt wird aber ich KANN den MBR nicht mehr korrigieren und, wie vor dem ersten chkdsk /f , findet testdisk absolut keine Dateien und Ordner mehr.

Wie bekomme ich nun wieder die richtigen CHS Daten auf meine Platte (hoffentlich sind die Daten jetzt auch noch da :evil:

Dumm wenn man ein Backup hat und dieses Problem nun auf genau diesem Backuplaufwerk passiert und man somit kein Backup mehr hat... :evil:

Ich hoffe sehr, das Ihr mir irgendwie mit einigen guten Tips weiter helfen könnt.
Vielen Dank und viele Grüße

Intru

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests