Missing option: "Unallocated space only"

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
AlienBeing
Posts: 3
Joined: 24 May 2018, 16:51

Missing option: "Unallocated space only"

#1 Post by AlienBeing » 24 May 2018, 17:06

Hello!

First of all thanks for this great utility. But yeah, I had this problem regarding PhotoRec that I hope someone can solve.

Situation is I deleted a photo from my 2TB NTFS Hard drive and I would like to recover it. There is nothing wrong with the drive, I just want to undelete the specific file.

So when I go through the steps I don't get the coise to look for "unallocated space only". It will take forever if I include all my photos what aren't deleted :D I tried running it for a while and it "recovered" a lot of photos I already have lol. But I ended up cancelling because it would all take 17 hours.

How can it be that I can't choose to only recover deleted files?


Thanks very much!
Kristoffer

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4429
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Missing option: "Unallocated space only"

#2 Post by cgrenier » 25 May 2018, 05:47

This option is available if you select a FAT12/16/32, exFAT, NTFS, ext2/3/4 filesystem.
Feel free to read https://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step or the chapter "Recovering deleted files using PhotoRec" from https://www.cgsecurity.org/testdisk.pdf

AlienBeing
Posts: 3
Joined: 24 May 2018, 16:51

Re: Missing option: "Unallocated space only"

#3 Post by AlienBeing » 26 May 2018, 10:48

Thanks a lot. But for some reason it is not. I chose NTFS because that's what my hard drive is. Here you can see the screenshots from the process which I initiated just to show you (I cancelled it). Sorry it is so small I can't make it larger :D

Image

User avatar
cgrenier
Site Admin
Posts: 4429
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Missing option: "Unallocated space only"

#4 Post by cgrenier » 27 May 2018, 08:16

You have select "whole disk", not an NTFS partition. Did you delete your NTFS partition ?

Another possibility is that Photorec identify by mistake the partition table as EFI GPT instead of PC Intel. In this case, you can enable the expert mode in Options, return to the disk selection, force the partition type to PC Intel, Search.
If you see this time an NTFS partition, select it. Start the recovery and use the default options.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests