Lost partition

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
dr5mn
Posts: 2
Joined: 27 Jun 2018, 08:45

Lost partition

#1 Post by dr5mn » 27 Jun 2018, 08:51

Hi

I ran into some problems after attempting a partition recovery.

Here is what happened more or less:
I was working on my Windows laptop. I inserted a USB flash drive which I had previously burned as a bootable Linux pen drive. I needed the pen drive for something else, so I wanted to wipe it, in order to be able to copy other files to it.

I was unable to format using Windows format, as it was not readable. Maybe because it was ext4 file system, I don't know.

I opened diskpart.

I listed the disks, and then selected the pen drive.

I then listed the volumes (or partitions, I cannot remember exactly)

I selected a volume (or partition) on the flash drive.

I ran the CLEAN command, hoping that the pen drive would be wiped.

Without me knowing, selecting the volume/partition, unselected the disk that was selected in step 4. Naturally the wrong disk was being wiped.

My laptop's hard drive had multiple partitions on it. One was the recovery, one was C:, and another was E: which just contained other data.

Running CLEAN then started to clean my laptop's hard drive!!! Luckily, it couldn't touch C: because that was the current operating system. It did however wipe E:, at least that's the one I know about. Not sure about the others.

I immediately removed the hard drive from the laptop.

I then ran TESTDISK in order to recover the wiped partition. Here is where the problem starts.

It found the missing partition, but after repairing it, my disk wouldn't boot. I even opened the hard drive in Linux with gparted, and tried to set the flag as bootable, to no avail.

I suspect its something small, like a flag, but I would like if you could provide some guidelines on how to restore my drive to the state it was before, with all partitions in tact, and also so that the computer can boor normally.

I do not blame TestDisk, only myself. I am not an expert, and I know just enough to be dangerous!

I will attach a log file in a subsequent post, hopefully you can make some sense of it.

I look forward to your response.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4286
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Lost partition

#2 Post by cgrenier » 27 Jun 2018, 17:13

Have you tried what is written in the chapter "How to make the system bootable again" from https://www.cgsecurity.org/testdisk.pdf ?

dr5mn
Posts: 2
Joined: 27 Jun 2018, 08:45

Re: Lost partition

#3 Post by dr5mn » 04 Jul 2018, 20:10

Hi

That was the first thing I tried.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests