Failed RAID0 after clean CMOS Topic is solved

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 12 Sep 2018, 04:25

Failed RAID0 after clean CMOS

#1 Post by Rods001 » 12 Sep 2018, 07:12


First my config: Maximus VII Formula, BIOS 3003. CPU i7 4790k.
Disks: KingDian (OS) , Samsung 103SJ 1TB 7200 RPM and ST1000 1TB 7200RPM (RAID0 Strip 128kb)


I was modifying my overclock, but something got wrong and I have to clean cmos / reset bios.

I couldn't know that I was going to impact in my RAID0. After I clean cmos I entered on BIOS and change SATA MODE from AHCI to RAID, save and exit.
After reboot the first screen was the Intel Rapid Storage Techonology telling that "MyRAID" was Failed stat.


So after this I started search in google and found many cases about it "reset cmos and raid...." I found a video on youtube and the guy recommended the TestDisk, I already have used it to recovery data, but not partition or RAID....
So in another link a guy has the same problem and used the TestDisk too, but when I try to recovery my data I just can recovery a part of it.

MyRAID0 was composed by 2 HD 1TB 7200RPM, and on Windows I created a partition of 931gb +/- to one drive and 931 +/- to other.
So I had "E:\"= (Files x64, x86, desktop, downloads, documents) and "F:\"=(Games, Steam, Origin, etc...)
Windows is on C:\ (KingDian SSD 240GB)

I dont know why, but my Windows 10 cant boot if the SATA MODE is on RAID the system crash and reboot to recovery mode, now in Recovery Mode I acess the CMD and execute the testdisk_win.exe by promt.

The testdisk found my partition, 3 partitions to be honest
3rd is the partition where I can acess the files, read them ok,
2nd is probably the data that I really want to recovery, but I can't recovery When I let it selected on the bottom shows NTFS Found using backup sector. blocksize=4096, 1000GB / 931GB
So I press P on it and "Can't Open Filesystem. Filesystem seems damaged.


And can't recovery all of them together too...

Please, can anyone help me ?

Sponsored links

User avatar
Site Admin
Posts: 4637
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Failed RAID0 after clean CMOS

#2 Post by cgrenier » 13 Sep 2018, 05:53

The 3 partitions found by TestDisk overlaps. Is the third partition your old F: ? Do you get more partitions after Deeper Search ?

Posts: 2
Joined: 12 Sep 2018, 04:25

Re: Failed RAID0 after clean CMOS  Topic is solved

#3 Post by Rods001 » 14 Sep 2018, 21:29

cgrenier wrote:
13 Sep 2018, 05:53
The 3 partitions found by TestDisk overlaps. Is the third partition your old F: ? Do you get more partitions after Deeper Search ?
Hello again,

It was strange result.

I fixed the Windows Boot to start again with Sata Mode RAID. So I ran again the TestDisk as admin and let it running for 2~3hours

It found
MS Data
Linux Something
MAC OS Something
MS Data
MS Data

This last 2 MS Data I found all my files, and I recovered everything, after this I have to Rebuild BS and restart my computer.

After it everything was fine again.

PS: Asus answered my ticket and they tells to me that it's not a bug or fail from BIOS. They tell me to do the exact thing that I did before.

Ofc after reset cmos I don't boot in Windows Directly , I have to access bios again and change to my old config (overclock, sata, and others things) and even doing everything correct the RAID broken... That's really strange.

Anyway in the end everything worked like a charm

Thank you so much guys.


Who is online

Users browsing this forum: Bing [Bot] and 8 guests