RAID 10 (0+1) messed up after BIOS update

How to use TestDisk to recover lost partition
Message
Author
wjjward
Posts: 4
Joined: 09 Jul 2012, 05:10

RAID 10 (0+1) messed up after BIOS update

#1 Postby wjjward » 09 Jul 2012, 07:14

Hello,

My system is as follows: ASUS Maximus IV Gene-Z mobo, Intel i7 2600 CPU. 4 x 2TB WDC HDD set up as a RAID 10 (0+1) RAID array from the mobo, using Intel IRST drivers.

I have Windows 7 Ultimate edition installed onto a 240 GB OCZ Vertex SSD. The SSD was had/ has two partitions, one for the OS and the other as 64GB Cache for IRST acceleration. The RAID (Volume A) was effectively one UEFI GPT partition which I created in the beginning by using DiskPart during the OS installation. It reads as 3.6TB in the intel IRST Option ROM menu.

Everything was working perfectly and as the saying goes, if it ain't broke don't fix it! Well I did just that and decided to update the IRST drivers to the latest 10.8 version in order to support the latest BIOS version.

The IRST driver update went perfectly after reboot. I then flashed the BIOS and on completion entered set up but forgot that everything was now in default. I exited BIOS and windows started to load but it was doing so in repair mode. It asked me if I wanted to repair the system. I said yes and after a time it said that repairs could not be made. Realising with horror my mistake I shut down the system to think what to do (at this time I was not aware of TestDisk).

I powered up again into BIOS and sure enough the SATA settings were set to AHCI rather than RAID. At this juncture I did not reset to RAID but I inserted my SPINRITE v6 data recovery tool to see if it would help. There were no options that I was happy with so I removed it without selecting any commands, however I fear that even this may have been unwise.

Anyway, after more research I reset the SATA to RAID mode and then entered into the IRST Option ROM (CTRL I). See image below:-

[img=http://s19.postimage.org/smsoc86z3/IRST_Option_ROM.jpg]

From the image you can see that the VOL A RAID 10 has failed and it shows that two of the WDC disks are non raid but the other two (4&5) are still members. I then made them (nos 4&5) non raid and the recreated a new RAID 10 Vol A, exactly as before, which basically was with default 64kb strips. All disks are in exactly the same order as before - none of the connections have been changed at all.

So with the RAID recreated I restarted, but the system will not properly start up. Windows still tries to load into repair mode, however I did not select any repair options. So far the only way I can get TestDisk to run is from a DOS environment CDRom (CAINE 5x) and when the TestDisk utility runs it only sees all the drives (SSD + 4 HDDs) individually. I have run quick scan on all drives but not made any 'write' instructions.

Disks 2 and 3 are showing up as being UEFI partition and disks 4 and 5 show up as Intel/PC which I don't understand. Anyway I am simply not sure what to do next as I am afraid to try any action that from this position can only be taken on an individual disk and hence I cannot see how it would lead to a reconstruct of the single GPT partition that existed across the four disks in the array.

My understanding is that TestDisk should 'see' the array when launched from windows. Should I reinstall windows onto the SSD and operate TestDisk that way, or can I perform the necessary recovery options from the DOS environment.

Ideally I would like to get the set up back to where it was before, however my priority is to recover my data.

Many thanks for your help and understanding.

Bill

Sponsored links

wjjward
Posts: 4
Joined: 09 Jul 2012, 05:10

Re: RAID 10 (0+1) messed up after BIOS update

#2 Postby wjjward » 10 Jul 2012, 05:15

Does anyone know how to access the TestDisk log file whilst working in a DOS environment? I am using TestDisk from the CAINE CD-ROM since my Windows 7 OS will not fully load.

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: RAID 10 (0+1) messed up after BIOS update

#3 Postby Fiona » 10 Jul 2012, 19:46

Spinrite would be probably able to repair softbads (bad sectors but not physically damaged ones).
As long as your RAID0 is intact it might be worth to have a diagnose of your array.
Although your RAID1 disk failed.
Some user using a camera to make a photo in low resolution and upload it.
I'd need infos from Analyse and Quick Search first.
If nothing would be found from Deeper Search also.
I'm a little bit confused about your disk size;
the first disk (RAID0) is 160 GB the second disk (member of RAID0) is 64 GB and your failed RAID1 displays 3.6 TB.

Fionba

wjjward
Posts: 4
Joined: 09 Jul 2012, 05:10

Re: RAID 10 (0+1) messed up after BIOS update

#4 Postby wjjward » 11 Jul 2012, 13:24

Working with TestDisk from a dos environment and only being able to see each disk in the array as an individual disk was no good for me and the SSD with the OS installation was also rendered as unbootable so I could not get TestDisk working from a windows environment.

However I have since recreated a new array from the IRST Option ROM as per original installation and I have now reinstalled W7 onto the SSD (GPT) and set a GPT over the RAID 10 array and windows now sees it as unallocated space (3.6TB), one single partition.

I can now run both PhotoRec and TestDisk from windows and this time the they both 'see' the 3.6TB raid array. Presently Photorec is running to recover files. On its second pass and showing more than 12 hours to go it has 'recovered' more than 200,000 files. When complete I will try to move/ save them to a safe place.


I'm a little bit confused about your disk size;
the first disk (RAID0) is 160 GB the second disk (member of RAID0) is 64 GB and your failed RAID1 displays 3.6 TB.


The first disk (160GB) and second disk (64 GB) - both members of RAID 0 are parts of one physical SSD (256 GB) which hold the operating system. The RAID1 3.6TB disk is physically four (2TB) disks in a RAID 10 config for applications and data. The Intel Rapid Storage Technology windows utility was used to create the 64 GB cache area on the SSD. Intel's own words best describe:-

Intel® Smart Response Technology is an Intel® Rapid Storage Technology (RST) caching feature that
improves computer system performance. It allows a user to configure computer systems with an SSD
used as cache memory between the hard disk drive and system memory. This provides the advantage of
having a hard disk drive (or a RAID volume) for maximum storage capacity while delivering an SSD-like
overall system performance experience. Intel® Smart Response Technology caching is implemented as a
single drive letter solution; no additional drive letter is required for the SSD device used as cache.

wjjward
Posts: 4
Joined: 09 Jul 2012, 05:10

Re: RAID 10 (0+1) messed up after BIOS update

#5 Postby wjjward » 12 Jul 2012, 14:02

A breakthrough at last....

Following on from the previous update where I was using PhotoRec to recover the files off the RAID disk. The tool certainly works, it recovered loads of files of every type conceivable and placed them into hundreds of different directories. However most of the files of interest had lost their original names so they were renamed with a numeric type name meaning that even after searching and sorting files by type you have to open each file to see its contents. Not really practical but if it was all you could get then definitely better than nothing.

So I went back to TestDisk and did some more deep searching to see if I could find evidence of the original single partition that sat over the whole 3.6TB array. I chose the one with the largest number of sectors which was labelled as a Primary. I altered it to a Logical, rebooted and bingo, there were all my files and programs in their original file structure -so far nothing found that is corrupted. I will say that I did not find it in any way easy or intuitive in trying to interpret the results of the searches by TestDisk but in the end it was patience and perseverance that paid off.

Given that I had to re-install windows onto the SSD (which I did just to the minimum workable level ie no updates or extra drivers etc in order to be able to use TestDisk in a windows environment) I will now have to reinstall all my software/ applications etc which will take time. However I am ecstatic to have recovered everything that is important data wise and doing reinstalls is a small price to pay for what was my own stupidity in the first place.

I will gladly make a donation.

Many thanks

DrChuckS
Posts: 2
Joined: 11 Aug 2012, 20:00

Re: RAID 10 (0+1) messed up after BIOS update

#6 Postby DrChuckS » 11 Aug 2012, 20:39

Thank you for your post as it gives me hope that I may be able to recover my data that was lost when I did a BIOS update on my Asus Sabertooth X79. I had just spent hours and hours moving DV Video from Tape to my computer. I thought that since I had setup my Data Storage as RAID 10 it would be pretty safe. Then I got stupid and decided to update my BIOS. Luckily I had my OS (Windows 7 Ultimate 64 bit) installed on a single SDD. When the BIOS update completed everything seemed fine and my system rebooted; however, my data was missing!. The BIOS update had reset the SATA from RAID to AHCI. So I went into the BIOS setup and changed back to RAID. NO JOY. Even though the RAID Name and associated data was still their two disks were shown as members and two as Non-Members, just as you indicated happened to you. I am still waiting on a response from ASUS. Looking around the Web i have not found away to repair my RAID 10 membership without destroying the data. So if I do not hear from ASUS in a day or so I will give you method a try using TestDisk.

Why would ASUS's BIOS update act this way? Why don't they warn folks? And why would it seem to keep most of the data intact except for only keeping half the disk is the RAID 10 as members? Does it expect to find a Raid 0 (or 1)?

In any case I will repost what ASUS says or the results of trying your solution when I try it. I would expect that as RAID 10 usage increases ASUS will be getting a lot of complaints!

DrChuckS
Posts: 2
Joined: 11 Aug 2012, 20:00

Re: RAID 10 (0+1) messed up after BIOS update

#7 Postby DrChuckS » 18 Aug 2012, 18:12

Here is a follow-up. ASUS never sent me any response that helped. Their last suggestion was resetting the CMOS which did nothing.

So I followed the suggestion above which worked. Thanks!

1. Enter the Intel Rapid Storage utility upon boot (CTL-I)
2. Remove any partitions that are still shown as raid members from the failed raid volume. The volume will disappear.
3. Create a new raid volume using the same parameters used to create the original failed raid volume
4. Exit the utility
5. Continue to boot into Windows. Note: the new volume will not be visable in Windows yet.
6. Run the TestDisk program
a. Select the newly re-created volume created above (it will be listed)
b. Run analyse using Intel Structure
c. The Structure will be found and indicated as good
d. Write the partition table
e. Exit TestDisk
7. Reboot Windows

All is now well, the volume shows up, and all data is present.

The process is a bit scary but only took about five minutes to complete and really saved me a lot of hours it would have taken to recreate all the data! :D

andymkl
Posts: 2
Joined: 18 Sep 2015, 08:08

Re: RAID 10 (0+1) messed up after BIOS update

#8 Postby andymkl » 18 Sep 2015, 08:41

I find myself in the exact same boat ... messed up after doing a BIOS update on a SABERTOOTH X79.
My 240GB boot SSD is just fine but the 3.6TB (4x 2TB) RAID 10 array has disappeared.
I've switched back to RAID mode in the BIOS and reconfigured the RAID as it had been previously.
Running TestDisk / Analse (Intel) / Deeper Search reveals my lost volume (marked as deleted, D).
If I press P to list files for the volume it correctly lists all the contents that I'd hope to recover ... its all there, which is great.

I change the partition to L (logical) and then Write the partition data .. then reboot.

But nothing happens the volume does not reappear.

What am I doing wrong? Any help would be greatly appreciated.
Thanks so much in advance.
Andy

User avatar
cgrenier
Site Admin
Posts: 3077
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: RAID 10 (0+1) messed up after BIOS update

#9 Postby cgrenier » 18 Sep 2015, 19:46

If you have a single partition, set it to *(bootable) before rewriting the partition table.

andymkl
Posts: 2
Joined: 18 Sep 2015, 08:08

Re: RAID 10 (0+1) messed up after BIOS update

#10 Postby andymkl » 19 Sep 2015, 10:59

Thanks so much for your reply.

I've done as you suggest but sadly without success. This time, as with every other attempt to resurrect the RAID, the process has left me with a single reportedly healthy 2TB RAW (unformatted) partition plus 1.5TB of space marked as Unallocated ... rather than a single RAID 10 volume with all my file intact. It doesn't seem to matter whether I select: *, bootable, P, primary or L, logical ... the result is always the same.

So, I was hoping for a major miracle, but it was not to be.

However, as I noted in my previous post, following the Deeper Search I am able to examine the missing directory ... and have now recovered all the lost data using that same function ... brilliant. All's well that ends well.

Many many thanks to the developers of this excellent tool.
Best
Andy


Return to “Partition Recovery”

Who is online

Users browsing this forum: No registered users and 0 guests