Uninitialized partition after power failure

How to use TestDisk to recover lost partition
Post Reply
Message
Author
toddbailey
Posts: 3
Joined: 10 Jul 2012, 18:17

Uninitialized partition after power failure

#1 Post by toddbailey » 10 Jul 2012, 18:27

In a nut shell, after a power fail a partition came up uninitialized.

more details

4 disk raid 5 array on an areca arc 1120 sata controller.

Drive was initialized using the controllers firmware, the disk was then
prepared for use under GParted Partition Editor where partition is
created and formatted as 1 JFS drive, total size is approaching 6tb, 4x
2 tb seagate drives

I'm running Fedora Linux F14 x64.

I was trying to install Fedora 17 and got 90 % complete
when the lights went out. Not sure if it was the power failure or a
mistake in selecting what drives to use for the install.

But after getting the machine back up and running the device /dev/sdc
has no partitions defined.

In Testdisk, I tried using intel format but it didn't work so I switched
to efi gpt and found the areca3 partition. I selected that one and did a
write and reboot but I can't mount the partition and fsck also fails.

can you offer a few pointers on how I might be able to recover the
partition?


Here is the mess I see after a quick scan under intel format:

TestDisk 6.12, Data Recovery Utility, May 2011
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/sdc - 6001 GB / 5589 GiB - CHS 715399 64 32

The harddisk (6001 GB / 5589 GiB) seems too small! (< 32 TB / 29 TiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

The following partitions can't be recovered:
Partition Start End Size in sectors
> FAT12 168535 48 3 2257495 60 30 4278190492
FAT16 LBA 1586878 53 29 3225922 22 30 3356761122
FAT16 >32M 2092362 30 12 2356790 8 1 541547829
FAT32 LBA 2123636 42 9 3467124 42 8 2751463424
FAT16 <32M 2258043 63 29 3916388 6 1 3396288709






[ Continue ]
17 TB / 15 TiB



Any ideas how to proceed?

Moving on to

Sponsored links

toddbailey
Posts: 3
Joined: 10 Jul 2012, 18:17

Re: Uninitialized partition after power failure

#2 Post by toddbailey » 10 Jul 2012, 19:34

Moving on to deep scan , but basically starting over,


I used fdisk to set the partition id to 83, same as the other partitions on the controller.
So basically I back to an uninitialized partition.
I've rerunning a quick scan that should complete in 18 hrs. or so.

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Uninitialized partition after power failure

#3 Post by Fiona » 10 Jul 2012, 20:18

I'm not as much a linux tech savvy
Your TestDisk message is only that some partitions are not recoverable because they end after disk limit.
I have no infos from the result.
Did TestDisk find your partition.
If your partition is already found and written into your partition table, you can have a try to repair your superblock.
http://www-01.ibm.com/support/docview.w ... g3T1000156
If you have problems repairing your superblock, please let me know.

Fiona

toddbailey
Posts: 3
Joined: 10 Jul 2012, 18:17

Re: Uninitialized partition after power failure

#4 Post by toddbailey » 12 Jul 2012, 14:51

I need to start over with this one and I may be making things worse.

when I first started using testdisk, It indicated the intel pc partition format.
When I realized I should have selected gpt I stopped testdisk scan and restarted under gpt.
This was under the assumption that intel-pc format only supported up to a 2 tb partition size

Using gparted, I see /dev/sdc1 as a JFS partition with the correct label

but I can't mount the partition[root@mythtv todd]# mount /dev/sdc1 /mnt/areca3 -t jfs
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


fsck doesn't work either


[root@mythtv todd]# fsck.jfs /dev/sdc1
fsck.jfs version 1.1.13, 17-Jul-2008
processing started: 7/12/2012 6.50.36
Using default parameter: -p
The current device is: /dev/sdc1
Superblock is corrupt and cannot be repaired
since both primary and secondary copies are corrupt.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest