Usb not accessible because of I/O device error

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
Gloria8733
Posts: 1
Joined: 07 Mar 2019, 07:22

Usb not accessible because of I/O device error

#1 Post by Gloria8733 » 15 Mar 2019, 10:01

Hi I have a 32G toshiba usb that is very important to me. every time when I try to access it I get this message "The request could not performed because of an I/O devices error" I searched on google to find the solution and the most appearing solution was to run this command "chkdsk /f m:".....m being the name of the drive.

I tried this but i get message "Cannot open volume for direct access"
diebestetest.de/
Last edited by Gloria8733 on 19 Mar 2019, 08:26, edited 1 time in total.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4971
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Usb not accessible because of I/O device error

#2 Post by cgrenier » 16 Mar 2019, 08:02

You should try to clone your USB key using ddrescue as described in https://www.cgsecurity.org/testdisk.pdf
Once it's done, remove the original device and run chkdsk on the clone.

Locked

Who is online

Users browsing this forum: No registered users and 11 guests