BIOS Reset RAID 10

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 14 Apr 2019, 04:43

BIOS Reset RAID 10

#1 Post by KillerG » 14 Apr 2019, 05:33

So I've been trying to diagnose a problem with Windows 10, it won't let me update to the newest feature update. One way I was trying to fix it was changing some settings and turning off a few things in the BIOS. I decided I needed to reset everything back to default and of course forgot to swap the settings back for RAID support. So I have a 4x6TB RAID 10 setup that's dead atm.

Right now in Disk Manager I have two disks unaccounted for. One that's 2794GB and has a large RAW partition, and another that's 11178GB and has two different unallocated partitions (that I had to "initialize"). As a side note, I have an SSD and two different storage drives to accompany the RAID and one of the storage drives isn't showing up too, rather odd.

I followed the suggestions to check my Intel BIOS setup. Two of the drives that were supposed to be in RAID were not, so I unselected the two that were and put the drives back in RAID 10. Then I followed the main guide for TestDisk, including finding files and everything, and wrote everything, figuring it would work. Fixed the boot, did everything I was supposed to do and I still got nothing. Now I can't even view the files that were there anymore. TestDisk is still finding the one partition, but I'm having it deep search atm to see if I screwed something up (does it matter if it's in Intel or EFI? EFI is incredibly slow and it was originally selecting Intel I think).

Am I doing something wrong here or am I just being impatient and not waiting on the deep search?

Sponsored links

User avatar
Site Admin
Posts: 5083
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: BIOS Reset RAID 10

#2 Post by cgrenier » 14 Apr 2019, 19:51

With disk over 2 TB (or Raid over 2 TB), you should use EFI GPT.

Posts: 2
Joined: 14 Apr 2019, 04:43

Re: BIOS Reset RAID 10

#3 Post by KillerG » 23 Apr 2019, 04:52

This is what I've got now and it told me that the two MS Data partitions are not recoverable. The second one was the right one. It needed a chkdsk run on it, but it worked afterward. All my files are there and it saved me the trouble of having Backblaze send me a hard drive.