Dynamic EFI GPT Spanned 2/3 deleted volume in windows installation. now 1/3 and 3/3 foreign and 2/3 unallocated basic

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
Piolon
Posts: 2
Joined: 14 Aug 2019, 14:27

Dynamic EFI GPT Spanned 2/3 deleted volume in windows installation. now 1/3 and 3/3 foreign and 2/3 unallocated basic

#1 Post by Piolon » 14 Aug 2019, 16:06

I had a spanned volume of 3 HD
Accidentlly I deleted volume of the second spanned EFI GPT partition during a Windows 10 installation on another drive.
I did not format it.
I installed windows on the other drive and I now see on windows Disk Management
the other 2 as foreign dynamic disks (Disk 0 and disk 1)
On cmd diskpart
Disk 0 shows as foreign 5589gb dyn gpt
Disk 1 shows as foreign 894 gb dyn gpt
Disk 2 shows as online 447 gb gpt - clean install of w10pro
Disk 3 online 894 gb —- the broken link of the spanned set, the one that shows as basic unnollocated

In test disk
After going to advanced menu off the efi gpt it doesnt read from any backup
It says no partition available
Have read a bunch on how to attempt to recover but have not adventured to do anything
I dont mind at all converting to basic disks. This would be actually nice too, been wanted to do it but did nit know it was possible.
I have handy ZAR, parition wizard 4.2 (the one that can convert to basic disk from dynamic as well) disk probe and dmdiag (extracted from a cab from xp), and of course, the king of them all testdisk 6.14.
What should I do? How should I proceed?
Its clear to me now after hours of reading that data is there and what its lost is the partition structure from deleting the volume.

I looked for lost partitions and it found nothing both in testdisl and partitionwizard. Just leaned that I had run the wrong one, the intel and the other normal button on the wizard which I assume is the same.

I found this, among them a couple of solutions, but im not sure if they are safe, and the efi gpt in testdisk will literally take forever...

https://www.z-a-recovery.com/archive/sp ... overy.aspx
https://jeffpar.github.io/kbarchive/kb/153/Q153973/
https://askubuntu.com/questions/509006/ ... table-type
https://www.itprotoday.com/windows-78/h ... windows-xp
https://www.easeus.com/resource/dynamic ... covery.htm

When i right click on windows manager disk to import the foreign disks, it does notify me that one spanned is missing. It is my understanding that it knows because all info about the 3 disks is on first one.

Again, what should I do? Should I attempt to tweak it manually? Meaning create a partition table manually? Or do the zar splution after importing the foreign and the run zar again? Or How should I do that on On testdisk?

Thank u in advance!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests