Recovering data from a dying Toshiba ext hdd

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
Nuller
Posts: 2
Joined: 06 Nov 2019, 23:54

Recovering data from a dying Toshiba ext hdd

#1 Post by Nuller » 07 Nov 2019, 00:53

Hello all,

I have a externally powered USB 3.0 2TB Toshiba canvio external hard drive that is internally a HDS5C3020BLE630.
The hard drive had been slow for quite a while, but except for long reading times from large zip files of data it was fine.
The hard drive had about 80 GB free space.
A few weeks ago, the hard drive stopped working completely. Upon closer inspection I found that the 12V 2A wall adapter for the hard drive was busted. I used a 12V 1.5A wall adapter for the hard drive and it was working fine.
A few days later I had to clean up my laptop, and copied another 40 gigs of data to this ageing hard drive. That was not a very smart move from my end, as I immediately notice that the hard drive now took about 6 hours after being plugged into Windows 10 to be accessible from windows explorer. So I bought a new external hard drive to move data from this hard drive.
As luck would have it, when I plugged in my Toshiba drive to copy files off it, the drive was not being detected at all. Finally, I bought a USB 2.0 enclosure for the drive. After plugging in I could see an inaccessible drive in explorer, which returns the error ‘ X: (drive letter) is not accessible, the parameter is incorrect.

1. Any attempt to check the drive status in Disk Management results in a irresponsible disk management window.
2. Windows explorer hangs and becomes unresponsive if I attempt to open the drive, and I was forced to power off the external, s even safely remove was hanging up.
3. Any attempt to check the SMART data results in the app, Crystal Disk, WD’s tool, or any other tool to hang. I’ve tried leaving it open for a day.
5. Chkdsk /f /x /r initially detected a lot of bad sectors and ‘fixed’ it. It took 1 hour for chkdsk to detect that the hard drive was NTFS, and total run time for chkdsk was about 6 days.
6. I attempted to use all windows based data recovery software I have used in the past like Easeus, Macrium, Active, but all of them HANGS when I plug in the external drive.

So with windows being pretty useless, I plugged the drive on to my Mac. The drive was not being detected at all.

7. Previously I had used testdisk, ddrescue, from partedmagic or other live distros or gparted to recover data for my friends with good success. So I booted up PartedMagic and attempted ddrescue.
8. ddrescue ETA was over 1855 days.
9. Gparted detected no other issues
10. Still my partition wouldn’t mount. The partedmagic mounter just keeps reopening without doing anything. With gnome I keep getting the error ‘unable to mount, operation already pending’ or the same error that ntfs3g gives me ‘unable to mount’ (forgot the exact error message)
11. So I tried to mount it with ntfs3g. It worked one time, and I began to copy important files from the disk. After a few files, the copy operation failed with some input/output error. I tried to resume it, but the hard drive wouldn’t mount again.
12. So I tried testdisk again, the partition was detected, I listed the files and started copying it off to another dive. I had to stop it in the middle since I was shifting my home. When I connected my hard drive again, all but one folder from the hard drive root was missing.
13. I tried to use testdisk again after a restart. All I get is this Linux partition listed, and not a NTFS partition.
14. I tried a deep search, got multiple read errors and it was taking forever.
15. Attempting NTFS-3G now gives the error that the disk has no valid NTFS partition.

The only disk Health data I could grab was using partedmagic’s disk health/gsmartcontrol. I’m attaching it on imgur as the forum is not letting me upload it saying attachment is too big. https://imgur.com/a/ZvU6Bgg

in short, using testdisk I managed to recover 50 gigs of my data and I had to stop. Now my folders are missing, possible partition too.
Any advice will be appreciated.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4972
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recovering data from a dying Toshiba ext hdd

#2 Post by cgrenier » 07 Nov 2019, 06:43

Try ddrescue with ddrutility as described in https://www.cgsecurity.org/testdisk.pdf
ddrutility will reduce the amount of data to copy.
Good luck

Nuller
Posts: 2
Joined: 06 Nov 2019, 23:54

Re: Recovering data from a dying Toshiba ext hdd

#3 Post by Nuller » 07 Nov 2019, 08:33

Thanks Greiner for the advice. I’m attempting to run ddru_ntfsbitmap now. But even reading $Bitmap is taking ages. Should I try to use a hard drive cloning dock instead?
Before attempting this, I tried testdisk again after letting the HDD cool at room temp overnight. The file list now shows two folders against one from before. Will letting the drive cool more help at all?

Edit:

Finally ntfsbitmap did it’s job and I began recovery with ddrescue, but the ETA started at 7 days and is steadily climbing. It’s sitting at 800 days now. :(

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 8 guests