My pe drive is detected, but not able to open

Using TestDisk to repair the filesystem
Post Reply
Message
Author
Vickybond
Posts: 4
Joined: 01 Aug 2012, 14:33

My pe drive is detected, but not able to open

#1 Post by Vickybond » 03 Aug 2012, 10:51

I brought a KINGSTON 16GB Data traveler, but I soon realized that it was a fake one. I used the pen drive rarely. All of a sudden the pen drive did not respond and did not open. When I insert the pen drive it is detected(status LED goes on) and the drivers are installed. But when I try to open the properties of the Pen drive It doesn't show the file system and nor the size of the disk, but it is detected as well as the drive is healthy in the Disk Management. The pen drive asks for formatting but fails to format even with the popup menu format as well as the Disk Management format. Please help me gain my pen drive back.
I posted the topic in the File Undelete section but i accidently locked the topic. I also tried to upload a docx file attachment for the problem but it failed. Please suggest valid idea.

Waiting in anticipation :?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3458
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: My pe drive is detected, but not able to open

#2 Post by cgrenier » 31 Aug 2012, 14:41

If the format operation failed, the disk is probably physically damaged and the disk has to be replaced.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests