Compilation with ZFS support Topic is solved

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 4
Joined: 25 Nov 2014, 21:13

Compilation with ZFS support

#1 Post by krichter » 25 Nov 2014, 21:28

I'm having trouble recovering ZFS partition from a disk image file (created with `dd`). The partition is recognized as `MS Data` type with `ext4` filesystem and when I want to change the type to `ZFS` I'm getting an error message ~`Support has been disabled during compilation`. In `configure --help` I don't see ZFS mentioned explicitly and `configure --with-zfs` and `configure --enable-zfs` aren't recognized. `config.log` doesn't contain the search term `zfs` or `ZFS`. I'm compiling on Ubuntu 14.10 amd64 and followed the instructions on

. `libzfs2` and `libzfs-dev` (0.6.3-13~utopic) from ppa:zfs-native/stable are installed. I'm about 100 % sure that I saw `ZFS` partitions being recognized before, but maybe that was something different.

Any help is appreciated.


Sponsored links

User avatar
Site Admin
Posts: 5046
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Compilation with ZFS support

#2 Post by cgrenier » 26 Nov 2014, 11:43

TestDisk can natively recover ZFS partition but it has no support to list the files from a ZFS partition.

Posts: 4
Joined: 25 Nov 2014, 21:13

Re: Compilation with ZFS support

#3 Post by krichter » 26 Nov 2014, 18:06

I misunderstood the `P=Primary` label like it undeletes the selected partition, but in the next row there's `P: list files` and now everything makes sense again :)