USB Flash Drives, etc. CHS don't match LBA

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 02 Mar 2015, 14:21

USB Flash Drives, etc. CHS don't match LBA

#1 Post by wptski » 02 Mar 2015, 21:14

This started with trying to undelete a short video on a microSD card from a camera. Using two different adapters and Testdisk from Linux Mintmate 17.1.

I get the "CHS don't match LBA" I later discovered out of about a dozen USB flash drives, microSD, SD, etc. I had two that didn't get that error. A brand new Sandisk Cruzer Glilde 8GB and a PNY 128GB USB 3.0 drive. I know these two haven't been formatted again but "not" the rest of them. I know for sure that some have but maybe not all.

I used Gparted right from Linux to partition/format and still got the error. I downloaded, installed Testdisk in W7 and don't get that error but get another but what error escapes me right now.

I have one more thing I want to try and may add to this post later if edits are allowed.

Sponsored links

User avatar
Site Admin
Posts: 4972
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: USB Flash Drives, etc. CHS don't match LBA

#2 Post by cgrenier » 03 Mar 2015, 07:49

If you don't have formated the memory card you want to recover video from, run TestDisk, Advanced, Undelete.
If it doesn't work or if you reformated the card, run PhotoRec instead.
If PhotoRec failed to run anything, enable the expert mode in Options, start a recovery, use a blocksize of 512, use the default options otherwise.

Posts: 2
Joined: 02 Mar 2015, 14:21

Re: USB Flash Drives, etc. CHS don't match LBA

#3 Post by wptski » 03 Mar 2015, 15:24

The deleted video wasn't important but I'm more concerned why 90% of my USB flash drives and memory card show the same "CHS and LBA don't match".

I took a 32GB microSD card, in DISKPART, cleaned, partitioned and, formatted FAT32 in the non-quick option. Testdisk in W7 shows the same error again. It states overlapping partitions but there is only one primary partition. Why?


Who is online

Users browsing this forum: No registered users and 3 guests