2TB Internal Drive Showing Empty

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 18 Aug 2017, 17:28

2TB Internal Drive Showing Empty

#1 Post by JackBenson »


I'm running a Slackware Linux system.

I turned my computer on today, and my internal 2TB drive is showing no data.

When I run testdisk /dev/sda and proceed through the steps, the 1st partition shows twice, along with partition 2 which contains my data. When I run a deeper search, I get errors regarding Bad jump in FAT partition and Bad number of sectors per cluster.

Am I looking at real data loss, or does this just sound like a partition table error?

Thank you in advance.

Sponsored links

User avatar
Site Admin
Posts: 5310
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: 2TB Internal Drive Showing Empty

#2 Post by cgrenier »

Without the testdisk.log file, it's difficult to understand the problem...
The partition table may be ok but the filesystem of the first partition is corrupted.

Read https://www.cgsecurity.org/testdisk.pdf and post more information relevant to your problem if you need help