Recovering data from a windows disk

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 13 May 2018, 18:43

Recovering data from a windows disk

#1 Post by barcode » 13 May 2018, 19:15

when i tried to start my windows laptop some time ago, i got the error "No Bootable Device".
I can't think of any reason what caused this (there was no strange behavior / noises).
This laptop had only windows installed.

I removed the drive and put in a different windows pc.
The disk does not always show up in the disk manager (when it shows up it shows an error).
Diskpart lists the disk but shows the size 0B (it is disk 2:

When i boot Linux (Ubuntu 14) and attach the disk it creates the devices:

When i run testdisk i get:

Code: Select all

$ sudo testdisk /dev/sg0 
TestDisk 6.14, Data Recovery Utility, July 2013
Christophe GRENIER <>

Unable to open file or device /dev/sg0

Usage: ...
The same happens for /dev/sda and photorec

Any ideas what i could try?

Thanks for all help.

Sponsored links

User avatar
Site Admin
Posts: 4806
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Recovering data from a windows disk

#2 Post by cgrenier » 15 May 2018, 11:46

Looks like a physical problem. You should contact a data recovery company.


Who is online

Users browsing this forum: No registered users and 0 guests