TestDisk FS recovery

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 09 May 2019, 11:58

TestDisk FS recovery

#1 Post by abhishekrayasam »


I am trying to restore the partition table on my Windows machine, but TestDisk shows no partitions when I choose Intel and analyze. I also tried unpartitioned media and other options, but after analysis, no partitions are shown. When selecting Intel, I see the following (screenshot attached).

Is there any way I can restore? The HDD is a 250GB SSD, but AFAIK the partition table seems to be showing invalid geometry. :?
Screenshot from 2019-05-09 11-02-25.png
Screenshot from 2019-05-09 11-02-25.png (107.49 KiB) Viewed 693 times

Sponsored links

User avatar
Site Admin
Posts: 5327
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: TestDisk FS recovery

#2 Post by cgrenier »

Can you run "sudo hexdump -C /dev/sda | head -40" and provide a screenshot ?