Drive Geometry Incorrect, Can not correct

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 14 Aug 2012, 00:17

Drive Geometry Incorrect, Can not correct

#1 Post by tcwnetops »

I've been working on a Western Digital PATA 80GB hard drive that suddenly failed to boot. I've run TESTDISK 6.11 on UBUNTU many times on the drive. The first time I ran TESTDISK, it reported that the drive geometry was incorrect - 255, 63, 512 and that it should be CHS 10338 240 63 512. I used the Geometry utility and reset the heads to 240 from 255 and then the drive reports correct partitions. When I go to Write after running a Deep Search, it instructs me to Shutdown, which I do by cleanly existing TESTDISK, then Shutdown of UBUNTU. When I restart TESTDISK and check the geometry of the drive, it reports the heads as 255 again. I have done this process repeated, but with the same results. It appears that I can not rewrite or over write the heads setting and that there is something wrong with the drive and TESTDISK can no longer help, am I correct?

Also, there are sections of the file system missing, whole directories gone and can not be seen or found via Deep Search.

Please confirm that most likely the LLF on the drive is the problem?

If you would like the latest TESTDISK Log file I can provide.

Thank you,


User avatar
Posts: 2835
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Drive Geometry Incorrect, Can not correct

#2 Post by Fiona »

Did you use your disk in another computer?
Normally 3.5 inch disks have a geometry of 16 heads per cylinder.
The computer controller from your motherboard convert it to 255 heads.
Using a 2.5 inch disk in a laptop/notbook it might be converted to 240 heads per cylinder.
But OS can change geometry also.
Linux for example can use 16 heads per cylinder.
In your case it looks like that your controller during boot is setting back geometry.
Do you miss any partition?
Missing any firectories can have several causes.
Faulty file system, incorrect boot sector etc..
Did you run a rebuild BS as a diagnose?
Please don't write, change anything to your file system.
That you wrote your partition table a couple of times didn't harm somehow, because it's only your MBR and 1 sector.
MBR code and partition table doesn't touch any data in your partition.
So there should be no changes.
Also older BIOS can have a virus protection and virus scanner and some software as a background process can prevent testdisk from writing an new partition table.
Symptoms are exactly like you described in your case.

Would it be possible to upload a log and a screen from Analyse (your current partition structur) using 240 and 255 heads?
Amount of sectors per head should always be 63.