Can't overwrite FAT32 boot sector

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
lchan79
Posts: 1
Joined: 14 Aug 2012, 11:00

Can't overwrite FAT32 boot sector

#1 Post by lchan79 » 14 Aug 2012, 11:13

Hi all,

Boot sector of my external USB HDD suddenly crashed.
I tried to recover it by TestDisk but it failed.

Code: Select all

copy backup boot sector over boot sector
file_pwrite(6,3,buffer,63(0/1/1)) write err Input/Output error
Write error: Can't overwrite FAT32 boot sector

fat32_boot_sector
 1 * FAT32 LBA                0   1  1 121599 254 63 1953503937
file_pread(6,16,buffer,63(0/1/1)) ReadFile Data error (cyclic redundancy check).


file_pread(6,1,buffer,63(0/1/1)) ReadFile Data error (cyclic redundancy check).
It seems the boot sector is damaged.
Does the boot sector become a bad sector?

Thanks.

Best Regards,
Lok

Sponsored links

Post Reply

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 6 guests