Help !! Can't recover data from SDcard

Using PhotoRec to recover lost data
Post Reply
Message
Author
thefan
Posts: 1
Joined: 15 Aug 2012, 19:30

Help !! Can't recover data from SDcard

#1 Post by thefan » 15 Aug 2012, 19:42

I really need help, I searched the net but no solution helped me...

I have a SAMSUNG Galaxy SII, and a Sandisc 16 GB HD micro SD card,
few days ago I noticed a notification that says:"SD card blank or has unsupported filesystem"

I tried several times to take it off and put it back but with no luck, I put the card in the card reader & connected it to my laptop, the laptop (windows 7) did't recognized it either, and it suggested to FORMAT the card, So I did, and choose to format to FAT32 system..I was hoping that recovery programs will recover my photos and videos...
sadly.. I tried 4 programs to recover them, no single photo was recovered, it just looks like a brand new Sd card now...the card now is working normally now...but I am not using it, just took one pic to test the card on the phone, and formatted it again using the phone..

I need my photos back, PLEASE HELP !!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3281
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Help !! Can't recover data from SDcard

#2 Post by cgrenier » 31 Aug 2012, 11:10

Formating was a very bad idea.
Run PhotoRec, enable the expert mode in Options, start a Search, use a blocksize of 512 bytes, use the default value otherwise.
Good luck

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 0 guests