Trying to recover 20TB LVM2 on Linux md

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 28 Aug 2012, 16:49

Trying to recover 20TB LVM2 on Linux md

#1 Post by rickatnight11 »

I've had an issue with a corrupted checksum on a single drive in my raid-6 md after every reboot. Following some instructions online, I stopped the array and recreated it with the --assume-clean option. The md created fine (although after reboot the drive still demonstrates a corrupted checksum, so I think the drive is borked), but the partition table on it is gone. I'm really hoping my data isn't gone.

When I run testdisk, it does immediately find an LVM2 partition in Quick and Deep scans, and while it and the md are both 20TB/18TiB, it says the hard-drive is too small:

Code: Select all

Disk /dev/md0 - 20 TB / 18 TiB - CHS 4883782460 2 4                                                                                   
The harddisk (20 TB / 18 TiB) seems too small! (< 23 TB / 21 TiB)                                                                     
Check the harddisk size: HD jumpers settings, BIOS detection...                                                                       
The following partitions can't be recovered:                                                                                          
     Partition               Start        End    Size in sectors                                                                      
  Linux LVM              512   0  1 588815615   1  4 39070259200
The fact that it can see the partition gives me hope that my data isn't gone, but I'm not sure what to do at this point.

User avatar
Site Admin
Posts: 5434
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Trying to recover 20TB LVM2 on Linux md

#2 Post by cgrenier »

There is no partition table on LVM2.
What is the results of
- pvdisplay
- vgdisplay
- lvdisplay