Scripted run syntax help Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 16
Joined: 19 Sep 2012, 11:41

Scripted run syntax help

#1 Post by stumpyuk » 19 Sep 2012, 11:56

I am trying to script out a command to carve a partition with the blocksize set to 512, here is my command:

Code: Select all

photorec /log /d unallocated /cmd /dev/sdc1 fileopt,everything,disable,txt,enable,freespace,blocksize,512,search

Here is my log:
Failed to set locale, using default 'C'.

Wed Sep 19 11:52:07 2012
Command line: PhotoRec /log /d unallocated /cmd /dev/sdc1 fileopt,everything,disable,txt,enable,freespace,blocksize,512,search

PhotoRec 6.14-WIP, Data Recovery Utility, March 2012
Christophe GRENIER <>
OS: Linux, kernel 3.0.0-25-generic (#41-Ubuntu SMP Mon Aug 13 17:58:59 UTC 2012) x86_64
Compiler: GCC 4.4
Compilation date: 2012-03-10T17:35:31
ext2fs lib: 1.41.9, ntfs lib: libntfs-3g, ewf lib: 20100226, libjpeg: 62
Hard disk list
Disk /dev/sdc1 - 7012 KB / 6848 KiB - CHS 856 1 16 (RO), sector size=512 - Generic USB CF Reader, FW:1.01

Load parameters from /home/ade/.photorec.cfg
Partition table type (auto): None
Disk /dev/sdc1 - 7012 KB / 6848 KiB (RO) - Generic USB CF Reader
Partition table type: None
check_FAT: Unusual number of reserved sectors 4 (FAT), should be 1.
check_FAT: Unusual number of reserved sectors 4 (FAT), should be 1.
Unknown 0 0 1 855 0 16 13696 [Whole disk]
P FAT12 0 0 1 855 0 16 13696
FAT12, 7012 KB / 6848 KiB

Interface File Select
167 first-level signatures enabled

P FAT12 0 0 1 855 0 16 13696
FAT12, 7012 KB / 6848 KiB
Pass 0 (blocksize=2048) STATUS_FIND_OFFSET
Elapsed time 0h00m00s
Pass 1 (blocksize=2048) STATUS_EXT2_OFF
unallocated.3/f0000064.txt 64-75
unallocated.3/f0000076.txt 76-79
unallocated.3/f0000080.txt 80-87
Elapsed time 0h00m05s
Pass 1 +3 files
txt: 3/3 recovered
Total: 3 files found

13596 sectors contains unknown data, 0 invalid files found and rejected.
PhotoRec exited normally.
I notice that in the log file, it indicates that the blocksize=2048. Is this just letting me know that the cluster size is 4 sectors or have I got the command syntax wrong? I want to be sure that the command successfully set the blocksize to 512 bytes.


Sponsored links

User avatar
Site Admin
Posts: 4637
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Scripted run syntax help

#2 Post by cgrenier » 30 Sep 2012, 10:03

The blocksize returned from "freespace" was overriding the value you specified.
I have uploaded a new 6.14-WIP. Can you try it and tell me if you still have the problem ?

Posts: 16
Joined: 19 Sep 2012, 11:41

Re: Scripted run syntax help  Topic is solved

#3 Post by stumpyuk » 04 Oct 2012, 19:11

Thanks Christophe, that version seems to work, the blocksize was reported as 512 bytes.

Thanks again!


Who is online

Users browsing this forum: No registered users and 2 guests