FAT32 File Table Recovery?

Using TestDisk to repair the filesystem
Message
Author
SteveB
Posts: 9
Joined: 12 Mar 2012, 17:38

FAT32 File Table Recovery?

#1 Postby SteveB » 12 Mar 2012, 18:01

First, thank you so much for a such a wonderful tool in Test Disk! I know it can help me solve some issues I've been having, but after repeated attempts, and reading the Wiki page numerous times, I am at a loss as to how best to solve my issue.

If anyone can help, I will try to be brief, but precise:
  • I have a 1TB external drive that contains two partitions – A journaled MAC partition (250gb) for backups and a FAT32 (750gb) partition for data.
  • The FAT 32 partition seems to have corrupted itself, but the mac partition is fine.
  • I can mount and see the FAT32 drive and files structure on both OS X, and Windows under Fusion VMware (OSX)
  • I cannot effectively copy the data off the drive – some will copy, most will not. I suspect corruption in the FAT tables.
  • In OS X, the copy function in finder will simply hang or will display the copy window indefinitely, with nothing actually copying off the drive, or it may copy partially, then hang, or sometimes display a corrupt data msg.
  • In Window (VM), it will begin copying until a point and then display a corrupt data message.
  • I have gone through the step by step as best I can:
  • TESTDISK correctly reads the partition structure and correctly shows the files structure and files.
  • I have [Analyzed] and verified the files and file structure
  • I have re-written and saved the partition tables with [Write]
  • I have re-built the BS so they are identical - initial pass indicated they were not identical
  • I have NOT repaired the FAT - How long might this take on a 750gb partition?

My question is should I try to repair the FAT or should I use PhotoRec to try to pull the files? The problem is I don't have a second drive of equal size to transfer the files to, so repairing is the preferred route if possible.

Any assistance is greatly appreciated.

Sponsored links

Digirec
Posts: 1
Joined: 12 Mar 2012, 19:13

Re: FAT32 File Table Recovery?

#2 Postby Digirec » 12 Mar 2012, 19:32

Hi Steve,

Although I have no direct answer to your queston, please follow this advise.
Before you do anything with your hardddrive, make an image first. I know you have said you have no spare drive of equal size...but a mistake is made very quickly and if you have an image somewhere you can allways start over again.

You have not repaired the File Allocation Table because of the time it might take.
I can only say: Welcome to the world of data recovery :)
Sometimes actions take a lot of time, some hours but some even days.

My advice: Get 2 extra equal drives. On to make an image to and one export your recovered data to (if nescesairy)
If you extract data with Photorec, you will see that you can easily get gigabytes of files.
If you only search for JPG's, of some other kind of files you will manage, but if you are going to search for every file Photorec can handle, you might not even have enough space on a 750 gb drive.

Maybe you can borrow a drive from a friend?!

Peter
Digirec Data Recovery

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: FAT32 File Table Recovery?

#3 Postby Fiona » 12 Mar 2012, 19:42

Don't use Repair FAT.
There has been a message, very dangerous and should only be used in conjunction with chkdsk.
Did you try to copy your data with TestDisk?
When you list your files in TestDisk you can copy them.
At the bottom of the screen you'll find all the commands.
TestDisk often gives a user the opportunity to copy data from a damaged file system.

SteveB
Posts: 9
Joined: 12 Mar 2012, 17:38

Re: FAT32 File Table Recovery?

#4 Postby SteveB » 12 Mar 2012, 21:09

Thank you both for the reply.

I never thought to copy the data using Testdisk. I will attempt to copy some files, and if I see success, I will expand my copy scope greater and greater. How does Testdisk locate the data when copying? Is it different then how the OS would access the data structure? I suppose this might identify whether it's the FAT tables or something else that has been corrupted.

Like I said, I did not use Rapair FAT. When I ran chkdsk, it would initiate a reboot in Windows, run on startup, but gave an error indicating it could not work on the drive. I can't recall the error, but I had no option but to continue booting the system. Basically, chkdsk could not perform any functions on the drive.

Because I am not an expert, is the following correct?
  • Because I can mount and view the drive, it's partitions, the file structure and content, the issue is *probably not with the MBR or the Partition tables?
  • The issue is probably the FAT tables because I only have issues when I try to access files, indicating the OS can't locate all the pieces

Creating an image is a good idea - I will see if I can pull something together. Once complete, can I delete data that I know I do not need? Would this speed up recovery on the data I am seeking to recover? Or will this disrupt the overall data structure?

Thank you again for the assistance, I will report back shortly on the above suggestions.

User avatar
cgrenier
Site Admin
Posts: 3077
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: FAT32 File Table Recovery?

#5 Postby cgrenier » 13 Mar 2012, 07:58

Do not modify the partition source in any way.
You can delete unwanted files on the destination (including files already copied by TestDisk) when still copying files using TestDisk, it's not a problem but it's better to wait to have recovered everything.

Once you have copied your files, if using Mac OS X, umount the FAT filesystem and try RepairFAT. If using Windows, start Windows in rescue mode and try it but restart as soon as you have exited from TestDisk.


Return to “Filesystem repair”

Who is online

Users browsing this forum: No registered users and 1 guest