TestDisk not fixing the problem.

How to use TestDisk to recover lost partition
Post Reply
Message
Author
pmishra747
Posts: 1
Joined: 10 Oct 2012, 10:51

TestDisk not fixing the problem.

#1 Post by pmishra747 » 10 Oct 2012, 11:04

Hi,

I have a Transcend 500 GB external hard drive. It was working fine until 2 days back it prompted for "format the disk, inorder to use it". Going through some forums, i tried to do chkdsk (chkdsk e: /f). It ran for almost 20 hours but didnt complete. only message i could see on screen was a repeated message "Correcting errors for the volume bitmap". i had to disconnect the HD.

Then i tried testdisk. it showed me there was no boot partition. I think it found it and i did write. again connected the HD but this time it said not accessible. Again ran Testdisk and did a deep search and found one partion (most probably it was the same one that i found earlier). with "p" option i can see my folders and files. so i did a write. but again the same issue is there. The HD is showing on my computer with drive letter assigned and also on disk manager. but not able to access it.

Any help would be highly appreciated.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3697
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: TestDisk not fixing the problem.

#2 Post by cgrenier » 13 Oct 2012, 17:53

To copy your files, run TestDisk, Advanced menu, List and select what to copy.
To fix the problem, let "chkfsk /f e:" finish its job. If there are read error message, you will have to clone the disk
http://www.cgsecurity.org/wiki/Damaged_Hard_Disk

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests