Failed WD MyPassport 1TB

How to use TestDisk to recover lost partition
Post Reply
Message
Author
transit72
Posts: 1
Joined: 15 Oct 2012, 06:52

Failed WD MyPassport 1TB

#1 Post by transit72 » 15 Oct 2012, 15:53

Hello everyone.
I have an external WD MyPassport 1TB disk and a few days ago, while I was copying a large file to it I noticed that the progress indicator stayed at the same point (about half-way through) for more than 5 minutes. So I tried to cancel the copy operation but nothing happened. In fact my laptop stopped responding completely and I had to power it off the hard way. Then I powered on again but the disk was not recognised by Windows - it was as if nothing was connected to the USB port. I plugged the disk to another laptop with Ubuntu and it wasn't able to recognise it either. I ran the 'smartctl' program to check the SMART status of the disk and although it reported that the disk was not SMART capable, at list it was accessible again! I plugged it to the Windows laptop and this time it was recognised! I ran HDDScan and got the results below:
WD_HDDScan.jpg
HDDScan
WD_HDDScan.jpg (73.48 KiB) Viewed 952 times
I decided to have it replaced, since it is still less than even a year old, but first I started backing up my files from it. This took me some time because I had to re-arrange files from my other external disk which are smaller and don't have much free space. In the end all that is left in the failed disk are about 200GB files of my cloned laptop disk (taken with clonezilla) which I want to keep for backup. But when I finally found the space to copy them, the WD disk was unrecognisable again! Now when I connect it to the USB port, it does not get a drive letter and it is reported as unformatted.
I downloaded and used testdisk but the Analyze option seemed to be going really very slowly: It took about 5 hours to reach only 4%, so I stopped it. Then I ran testdisk again with the intension of letting it as long as it takes (this meant that my laptop would be grounded for a few days, but anyway...). After about 10 hours it was at around 7% and there was an error saying that some block could not be read (I don't remember exactly) but the analysis was continuing so I let it go. After more than 24 hours, I came back from work and it must have finished, but without any indication that it has found anything. Does anyone have any recommendation what to try next? Is there any point trying the advanced options?

Thanks, and sorry for the long post..

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests