ext3 Logical Volume on RAID0

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
bitronictech
Posts: 2
Joined: 16 Nov 2012, 05:14

ext3 Logical Volume on RAID0

#1 Post by bitronictech » 16 Nov 2012, 09:22

I was running a Xen virtualization, after rebooting one of my VPS the files were all gone. Of course I ran fsck fsck said the drive was clean, with 6500000 files. I mounted the drive, nothing there. I tried using fsck.ext3 -p -b superblock -B blocksize device to recover the filesystem... no luck.

Still nothing there. I installed testdisk on my Dom0 and unmounted the logical volume. I ran testdisk and it saw all the top level folders, but said the filesystem was damaged and it could not access the inner folders. i tried fsck.ext3 -p -b superblock -B blocksize device on a few of the superblocks, no luck. Now I'm using photorec to get the files, but they will be useless without name or structure. Is there any way to restore a working filesystem to the volume?
Last edited by bitronictech on 18 Nov 2012, 07:16, edited 1 time in total.

Sponsored links

bitronictech
Posts: 2
Joined: 16 Nov 2012, 05:14

Re: ext3 Logical Volume on RAID0

#2 Post by bitronictech » 18 Nov 2012, 07:15

I'm sorry the disks were in a RAID 0

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 5 guests