Help 1tb wd portable hd fail.

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 09 Jan 2013, 12:17

Help 1tb wd portable hd fail.

#1 Post by kaito »

The WD My Passport 1tb WDBACX0010BBK-00 was working fine until a few days ago my brother didnt use safely remove hardware and turn off the computer. It was plugged and nothing happened. I tried it on multiple computers with the same results.

The Symptoms :

Searches for drivers when plugged in. Ends up as follows :
USB Mass Storage Device ..................... X Ready to use
WD My Passport 0730 USB Device ............X Failed
WD SES Device USB Device ................... X Failed
Does not show up in My Computer.
Does not show up in Disk Management.

Steps taken :

Installed WD SES Driver. No luck.
Disabled the SES from the Device Manager (takes forever) then re-enabled it. Now :
I still can't see it in My Computer.
I can see it in Disk Management (Unallocate) but it shows as 134217727.97 GB (I wish!!!), and not initialized. Attempts to initialize it fail.
WD utilities (Firmware updater and WD Smartware) see it, but ask for a password. I have never set a password.
Now im using testdisk but i dont know it is working or not bc it is hard to tell.